Package Details: zrythm-git 0.6.422-1

Git Clone URL: https://aur.archlinux.org/zrythm-git.git (read-only, click to copy)
Package Base: zrythm-git
Description: a highly automated and intuitive digital audio workstation
Upstream URL: https://www.zrythm.org
Keywords: audio daw
Licenses: AGPL3
Conflicts: zrythm
Provides: zrythm
Submitter: alexteee
Maintainer: quenyen
Last Packager: alexteee
Votes: 4
Popularity: 0.52
First Submitted: 2018-11-18 02:16
Last Updated: 2019-09-21 12:33

Latest Comments

1 2 Next › Last »

lesiserfg commented on 2020-09-27 07:46

I disabled the doc generation (it's introducing a lot of dependencies) and did the sed changes and the latest version is working fine

diff --git a/PKGBUILD b/PKGBUILD
index 169d832..47d438e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Alexandros Theodotou <alex@zrythm.org>
 _pkgname=zrythm
 pkgname=$_pkgname-git
-pkgver=0.6.422
+pkgver=1.0.0.ralpha.2.0.1.42.g5f38e1d60
 pkgrel=1
 pkgdesc='a highly automated and intuitive digital audio workstation'
 arch=('x86_64' 'i686')
@@ -23,12 +23,12 @@ md5sums=('SKIP')
 pkgver () {
   cd "$srcdir/$_pkgname"
   #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-  printf "%s" "$(git describe --tags | sed 's/-/\.r/' | sed 's/v//g' | sed 's/-/\./')"
+  printf "%s" "$(git describe --tags | sed 's/-/\.r/' | sed 's/v//g' | sed 's/-/\./g')"
 }

 build() {
   cd "$srcdir/$_pkgname"
-  meson build --prefix=/usr -Denable_tests=true -Duser_manual=true -Dmanpage=true
+  meson build --prefix=/usr -Denable_tests=true -Duser_manual=false -Dmanpage=false
   ninja -C build
 }

ruestique commented on 2020-09-22 21:39

meh

meson.build:694:2: ERROR: Dependency "gtksourceview-3.0" not found, tried pkgconfig and cmake

ruestique commented on 2020-09-22 21:36

@lesiserfg thanks!

ruestique commented on 2020-09-22 21:34

==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: 1.0.0.ralpha.0.1.1.37-g1f38598c

lesiserfg commented on 2020-09-22 09:22

Version 1.0 alpha is out, to make it work just append g to the sed 's/-/\./'

alexteee commented on 2019-02-12 11:47

added

sekret commented on 2019-02-12 08:07

Please add ffmpeg to depends.

alexteee commented on 2019-01-25 07:39

@pdesaulniers added

pdesaulniers commented on 2019-01-25 01:28

Seems like this package also depends on libcyaml-git.

alexteee commented on 2019-01-01 16:09

@Yosh oops, added now