Package Details: zookeeper 3.5.5-1

Git Clone URL: https://aur.archlinux.org/zookeeper.git (read-only)
Package Base: zookeeper
Description: Open-source server which enables highly reliable distributed coordination
Upstream URL: https://zookeeper.apache.org/
Licenses: Apache
Submitter: srl
Maintainer: cramaker
Last Packager: cramaker
Votes: 31
Popularity: 0.084470
First Submitted: 2012-06-29 03:51
Last Updated: 2019-07-16 00:19

Latest Comments

1 2 3 4 5 6 ... Next › Last »

cramaker commented on 2019-08-02 17:32

@xyproto Of course, feel free to adopt and move over to [community] - let me know if you need anything on my end.

xyproto commented on 2019-08-02 11:39

Hi, would you mind if I adopted and moved this package to [community]?

fatalcoder commented on 2018-11-21 00:56

@cramaker output was from yay. aurman updated without issues

cramaker commented on 2018-11-20 18:17

@fatalcode The checksum matches correctly with the tar'd source files that yaourt pulls down for me when building from the AUR:

=> Validating source files with sha256sums...
    zookeeper-3.4.13.tar.gz ... Passed
    systemd_zookeeper.service ... Passed
    systemd_zookeeper@.service ... Passed
    systemd_sysusers.d_zookeeper.conf ... Passed
    systemd_tmpfiles.d_zookeeper.conf ... Passed
==> Extracting sources...
  -> Extracting zookeeper-3.4.13.tar.gz with bsdtar

If you can provide me with any more details, I'll attempt to reproduce on my end, but so far everything looks good.

fatalcoder commented on 2018-11-19 09:07

==> Validating source files with sha256sums...
    zookeeper-3.4.13.tar.gz ... FAILED
    systemd_zookeeper.service ... Passed
    systemd_zookeeper@.service ... Passed
    systemd_sysusers.d_zookeeper.conf ... Passed
    systemd_tmpfiles.d_zookeeper.conf ... Passed
==> ERROR: One or more files did not pass the validity check!
Error downloading sources: zookeeper

cramaker commented on 2018-11-01 17:11

@jerry73204 Thanks for the heads-up: pkgrel numbers have been reconciled

jerry73204 commented on 2018-11-01 04:40

PKGBUILD and .SRCINFO have different pkgrel numbers.

cramaker commented on 2018-02-01 15:23

Thanks for the suggestion! I've updated the PKGBUILD using the suggested lines to find the closest Apache mirror.

callofdutyops commented on 2018-02-01 02:52

Firstly, thanks for your hard working! Could you please modify the downloading source like this (copy from your another package named kafka):

_apache_cgi="http://www.apache.org/dyn/closer.cgi"
_closest=$(curl "${_apache_cgi}?asjson=1" | tr -d '\n ' | sed -r 's/.*"preferred":"(.+)".*/\1/')

This can speed up the downloading speed.

cramaker commented on 2017-12-12 15:50

Adopting package and updating to 3.4.11