Package Details: zfs-utils-git 2:2.0.0rc1.r38.gcd80273909-1

Git Clone URL: https://aur.archlinux.org/zfs-utils-git.git (read-only, click to copy)
Package Base: zfs-utils-git
Description: Userspace utilities for the Zettabyte File System.
Upstream URL: https://zfsonlinux.org/
Licenses: CDDL
Conflicts: zfs-utils
Provides: zfs-utils=2.0.0rc1.r38.gcd80273909
Submitter: minextu
Maintainer: eschwartz
Last Packager: eschwartz
Votes: 5
Popularity: 0.000000
First Submitted: 2018-11-11 00:44
Last Updated: 2020-09-04 05:18

Dependencies (2)

Required by (38)

Sources (3)

Latest Comments

« First ‹ Previous 1 2

minextu commented on 2017-11-02 21:21

Does /usr/lib/systemd/system/zfs-import.target exists on your system?

ArnoW commented on 2017-11-02 16:18

@minextu: Thanks for your reply.
Kernel is 4.13.9-1-ARCH, all packages are up to date. I have zfs only for data, root is not on zfs.
The issue shows up on all (two) my machines which run with the zfs-git-version. With the current packkage installed no automount on boot, with the older one (0.7.0.r152.gf4ae39a19-1) no problems.
The difference in the zfs-mount.service file I referred to is:
0.7.0.r152...:
After=zfs-import-cache.service
After=zfs-import-scan.service
is replaced by:
0.7.0.r157...:
After=zfs-import.target

As there is no "zfs-import.target" on my installations I thought that to be the problem.

minextu commented on 2017-11-02 15:10

@ArnoW Everything seems to work fine on my pc.
Did you update zfs-[kernel] along with the zfs-common package?
Are you using zfs on your root partition and which kernel do you use?

ArnoW commented on 2017-11-01 18:21

In version 0.7.0.r157.gc9427c469-1 the zfs-mount.service seems to be broken. Mount depends on zfs-import.target, but there ist no such target. So automount on system boot does not work.