Package Details: zfs-utils-git 2:2.0.0rc1.r38.gcd80273909-1

Git Clone URL: https://aur.archlinux.org/zfs-utils-git.git (read-only, click to copy)
Package Base: zfs-utils-git
Description: Userspace utilities for the Zettabyte File System.
Upstream URL: https://zfsonlinux.org/
Licenses: CDDL
Conflicts: zfs-utils
Provides: zfs-utils=2.0.0rc1.r38.gcd80273909
Submitter: minextu
Maintainer: eschwartz
Last Packager: eschwartz
Votes: 5
Popularity: 0.000000
First Submitted: 2018-11-11 00:44
Last Updated: 2020-09-04 05:18

Dependencies (2)

Required by (43)

Sources (3)

Latest Comments

1 2 Next › Last »

heppu commented on 2021-01-13 12:18

Thanks for the fast reply @eschwartz! I just realised what you said and removed the comment before noticing you had already replied. I was able work around the problem by downgrading autoconf to 2.69.

eschwartz commented on 2021-01-13 12:02

Since this is a -git package, it is already v2.0.1, which you'd know if you tried building it. But v2.0.1 does not fix the build -- we are waiting on a new autoconf release (which upstream autoconf said they were going to release in a couple of days, but that was at the beginning of last week).

esrevinu commented on 2020-12-29 18:52

Why is zpool import going into run_latehook function? Although zvol swap is not recommended for hibernation, I tried it. If zpool import is in run_latehook, resume does not work since zvol is not seen at the moment. So, I moved it into run_hook function and resume works. I am using ZFS on LUKS disk encryption.

Edit: I misunderstood. It is ZFS filesystem, not zvol swap that may cause a corruption with hibernation. https://github.com/openzfs/zfs/issues/260 Besides that, zvol swap can cause a deadlock under memory pressure.

grmblfrz commented on 2020-04-06 15:36

The latest update of this package rendered my system unbootable because of changes in zfs.initcpio.hook. It lacks fixes for grub ZFS= syntax. Could you please restore the zfs hook from the previous version?

javashin commented on 2019-07-11 20:56

Sorry Im Wrong There Is Nothing Bad With This Or The Other PKG all are updated

javashin commented on 2019-07-11 20:56

Sorry Im Wrong There Is Nothing Bad With This Or The Other PKG all are updated

javashin commented on 2019-07-08 20:59

this pkg install old zfs zpool --version zfs-0.8.0-116_g1086f5421 zfs-kmod-0.8.0-1

dmp1ce commented on 2017-11-07 15:41

I reported the issue here: https://github.com/archzfs/archzfs/issues/186 in case anyone else has the problem I had.

dmp1ce commented on 2017-11-07 15:29

I also had to `sudo systemctl enabled zfs-import` again after my update to 0.7.0.r167.g23ea00a1f-1.

This is a serious issue IMHO. It causes quite a scare when you reboot to not have any of your pools mounted.

ArnoW commented on 2017-11-02 22:11

There was no /usr/lib/systemd/system/zfs-import.target with zfs-utils-common-git-0.7.0.r152.gf4ae39a19-1, but in zfs-utils-common-git-0.7.0.r157.gc9427c469-1 it is there.
So this change caused my problems since this obviously new zfs-import.target was not enabled on my systems. After enabling it everything is back to normal again.
Thank you very much for your effort.