Package Details: zfs-linux-rt 0.8.4_5.6.17.9.1-1

Git Clone URL: https://aur.archlinux.org/zfs-linux-rt.git (read-only, click to copy)
Package Base: zfs-linux-rt
Description: Kernel modules for the Zettabyte File System.
Upstream URL: https://zfsonlinux.org/
Licenses: CDDL
Groups: archzfs-linux-rt
Conflicts: spl-dkms, spl-dkms-git, zfs-dkms, zfs-dkms-git, zfs-dkms-rc
Provides: spl, zfs
Submitter: szanni
Maintainer: szanni
Last Packager: szanni
Votes: 2
Popularity: 0.99
First Submitted: 2020-03-22 18:03
Last Updated: 2020-08-04 18:02

Dependencies (4)

Required by (16)

Sources (1)

Latest Comments

szanni commented on 2020-08-04 18:08

Thanks for reporting the issue upstream. I actually have the same problem, just retested with kernel 5.6.19.11. The issue persists. I reverted the package to the last working version.

kuon commented on 2020-07-11 20:44

I have the same issue as here when trying to install your package:

https://github.com/openzfs/zfs/issues/10503

The gist of the error is:

zfs-linux-rt/src/zfs-0.8.4/include/spl/sys/mutex.h:113:2: error: implicit declaration of function ‘VERIFY3P’ [-Werror=implicit-function-declaration]
  113 |  VERIFY3P(mutex_owner(mp), ==, NULL);   \
      |  ^~~~~~~~
./include/linux/ww_mutex.h:358:2: note: in expansion of macro ‘mutex_destroy’
  358 |  mutex_destroy(&lock->base);
      |  ^~~~~~~~~~~~~

I wonder if you had this issue and if you found a solution.