Package Details: zfs-dkms 0.8.3-1

Git Clone URL: https://aur.archlinux.org/zfs-dkms.git (read-only, click to copy)
Package Base: zfs-dkms
Description: Kernel modules for the Zettabyte File System.
Upstream URL: https://zfsonlinux.org/
Licenses: CDDL
Conflicts: spl-dkms
Provides: spl-dkms, zfs
Replaces: spl-dkms
Submitter: isiachi
Maintainer: eschwartz
Last Packager: eschwartz
Votes: 91
Popularity: 3.13
First Submitted: 2015-08-31 12:01
Last Updated: 2020-01-27 19:53

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

cyounkins commented on 2020-01-14 19:38

I think this needs build depends on automake and autoconf? Thank you for maintaining this.

freswa commented on 2020-01-07 13:44

Kernel 5.4 is working fine.

sphere101 commented on 2020-01-07 13:43

Does anyone know if zfs-dkms will work with the linux 5.4 Kernel?? Thank you.

xiaoliniess commented on 2019-12-27 12:03

@Tom_B I've manually tried the compilation, seems zfs configure does a lot compilation test and the configure process is single threaded, so no matter how powerful you machine is, it takes considerable time to complete.

Tom_B commented on 2019-12-20 23:04

Scratch my previous comment. It just takes a significant amount of time to install the module. Other DMKS modules I have installed take 10-15 seconds. ZFS takes around 10-15 minutes. I've no idea why this is but is why it appears to hang during a kernel upgrade. It doesn't hang, it just takes a lot longer than I'd expect.

Tom_B commented on 2019-12-16 13:40

Every time I get a kernel update, the dkms install hangs:

: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Install DKMS modules
==> dkms install zfs/0.8.2 -k 5.4.3-arch1-1

Previously, ctrl-c to exit exited the install and I could modprobe zfs as expected. Now though I get this error:

Error! Bad return status for module build on kernel: 5.4.3-arch1-1 (x86_64)
Consult /var/lib/dkms/zfs/0.8.2/build/make.log for more information.

The log it mentions:

DKMS make.log for zfs-0.8.2 for kernel 5.4.3-arch1-1 (x86_64)
Mon 16 Dec 13:36:46 GMT 2019
make: Entering directory '/var/lib/dkms/zfs/0.8.2/build/module'
make: *** No targets specified and no makefile found.  Stop.
make: Leaving directory '/var/lib/dkms/zfs/0.8.2/build/module'

Do I just need to wait for an update or am I missing something?

archfroggy commented on 2019-11-14 15:11

Hi, quick noob question. I am currently using zfs-dkms-git and want to switch back to zfs-dkms on an encrypted ZFS root. Everytime I try this I cannot boot anymore and I am dropped into the emergency shell with "filesystem 'rpool/ROOT/arch' can not be mounted: Permission denied". I can mount the pool inside the emergency shell just fine. Any ideas on how to fix this would greatly appreciated! Thanks

eschwartz commented on 2019-10-02 01:12

@Y5Lf8U0y5wFg4ktU is correct, the packages are designed so that you can build them without the other installed, but you need to pacman -U them both at the same time when upgrading. Most AUR helpers don't know how to do that, so you could try looking for one that does know how. Off the top of my head, aurutils does know how to behave properly here.

Y5Lf8U0y5wFg4ktU commented on 2019-10-01 09:36

It is easiest to build both packages and then upgrade them both at the same time. No need to remove anything.

If you use yaourt, just ignore the pacman errors, the packages will remain in your temp dir. Afterwards install them from there.

sphere101 commented on 2019-09-30 19:50

Had to remove both pacakges, then re-install utils and then zfs-dkms... Thanks