Package Details: zfs-dkms 0.8.3-1

Git Clone URL: https://aur.archlinux.org/zfs-dkms.git (read-only, click to copy)
Package Base: zfs-dkms
Description: Kernel modules for the Zettabyte File System.
Upstream URL: https://zfsonlinux.org/
Licenses: CDDL
Conflicts: spl-dkms
Provides: spl-dkms, zfs
Replaces: spl-dkms
Submitter: isiachi
Maintainer: eschwartz
Last Packager: eschwartz
Votes: 90
Popularity: 2.30
First Submitted: 2015-08-31 12:01
Last Updated: 2020-01-27 19:53

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

fryfrog commented on 2020-02-12 07:38

As a point of comparison, have you tried archzfs/zfs-dkms? While they're similar, they are slightly different.

Another option would be building the kernel yourself too, w/ the couple of patches to help ZFS.

https://hastebin.com/zuyolixaru.diff

^ This is what I'm currently applying to my self built kernel.

SRossi commented on 2020-02-12 06:14

@eschwartz No matter what I do - reinstalling all related zfs packages including kernel and kernel headers etc. - I can't get the modules to build or install. Even worse, I can't get it to work with kernel 5.4.15 anymore either, the kernel that the system (booting from zfs) is currently running with. It looks like a bug upstream or some issue with some package hooks maybe, where stuff gets pulled from underneat dkms leaving it in a bad state?

As a workaround I replaced zfs-dkms with zfs-linux for now. I will try with the long-term kernel again after a reboot later today and maybe be able to provide more information.

eschwartz commented on 2020-02-11 15:02

@SRossi,

It builds fine for me. Did you try manually running sudo dkms install zfs/0.8.3 -k 5.4.18-1-lts?

SRossi commented on 2020-02-11 14:08

I used to run stable kernels with zfs-dkms but since 5.5.x is not working with zfs, I would like to switch to the lts kernel tree.

(3/4) Install DKMS modules ==> dkms install zfs/0.8.3 -k 5.4.18-1-lts configure: error: *** Unable to build an empty module.

Is there any chance to get this done?

storm.continuity commented on 2020-02-11 10:05

Build on 5.4.8 seems to be working flawlessly.

My installed version is: aur/zfs-dkms 0.8.3-1 (+90 2.98%) (Installed)

Any news on the 5.5.2 kernel release?

tleydxdy commented on 2020-02-04 19:36

Build for zen kernel 5.4.15 fails with weird errors

/var/lib/dkms/zfs/0.8.3/build/configure: 13381: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_COMMON+= --define "$(DEBUG_KMEM_ZFS) 1": not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13382: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_COMMON+= --define "$(DEBUG_KMEM_TRACKING_ZFS) 1": not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13383: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_COMMON+= --define "$(DEBUGINFO_ZFS) 1": not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13384: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_COMMON+= --define "$(ASAN_ZFS) 1": not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13403: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_UTIL+= $(DEFINE_INITRAMFS): not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13404: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_UTIL+= $(DEFINE_SYSTEMD): not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13405: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_UTIL+= $(DEFINE_PYZFS): not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13406: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_UTIL+= $(DEFINE_PYTHON_VERSION): not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13407: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_UTIL+= $(DEFINE_PYTHON_PKG_VERSION): not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13418: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_KMOD+= --define "ksrc $(LINUX)": not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13419: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_KMOD+= --define "kobj $(LINUX_OBJ)": not found
/var/lib/dkms/zfs/0.8.3/build/configure: 13420: /var/lib/dkms/zfs/0.8.3/build/configure: RPM_DEFINE_KMOD+= --define "_wrong_version_format_terminate_build 0": not found
configure: error:
    *** Unable to build an empty module.

Error! Bad return status for module build on kernel: 5.4.15-zen1-1-zen (x86_64)

ceratophllum commented on 2020-02-04 13:02

Build of zfs-dkms is failing again with kernel 5.5.1:


FATAL: modpost: GPL-incompatible module zfs.ko uses GPL-only symbol '__rcu_read_unlock'
make[2]:  [scripts/Makefile.modpost:94: __modpost] Error 1
make[1]:  [Makefile:1606: modules] Error 2
make[1]: Leaving directory '/usr/lib/modules/5.5.1-arch1-1/build'
make: *** [Makefile:30: modules] Error 2
make: Leaving directory '/var/lib/dkms/zfs/0.8.3/build/module'

thedanbob commented on 2020-02-04 13:00

Linux 5.5.1 breaks ZFS 0.8.3. If you're willing to patch your kernel there's a workaround here: https://github.com/zfsonlinux/zfs/issues/9745#issuecomment-573205923

fryfrog commented on 2020-01-14 21:06

It is assumed by all AUR packages that base-devel is installed.

cyounkins commented on 2020-01-14 19:38

I think this needs build depends on automake and autoconf? Thank you for maintaining this.