Package Details: zenpower-dkms-git 46.5e2f56f-1

Git Clone URL: https://aur.archlinux.org/zenpower-dkms-git.git (read-only, click to copy)
Package Base: zenpower-dkms-git
Description: Linux kernel driver for reading sensors for AMD Zen family CPUs
Upstream URL: https://github.com/ocerman/zenpower
Licenses: GPL
Provides: zenpower
Submitter: Benzhaomin
Maintainer: Benzhaomin
Last Packager: Benzhaomin
Votes: 11
Popularity: 0.085633
First Submitted: 2019-06-20 18:50
Last Updated: 2020-06-28 07:56

Latest Comments

grdgkjrpdihe commented on 2020-08-03 14:21

cant install when using linux-zen kernel , bucause linux-zen isnt in the linux-headers group , but if i simply replace linux-headers with linux-zen-headers , all works fine . it seems better if remove linux-headers from depends , just like zenpower-dkms

Benzhaomin commented on 2020-01-07 18:40

@ridobe: sorry for the delay, I missed notifications from Github, updated.

@mareex: thanks for your comment, redundant/wrong depends were removed.

mareex commented on 2019-11-04 13:53

The quality of this PKGBUILD has to be much improved.

Why does this PKGBUILD depend on linux? It tries to pull the linux package from core, that I don't want to use because I use custom kernels. As this is a dkms package it schould only has "linux-headers" as "makedepends". See https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/vhba-module as a reference.

Also gcc and make are in the wrong place and redundant. As they are only used for building they should be put in "makedepends". But even that is kind of forbidden because when building with makepkg it is assumed to have the base-devel group installed. See https://wiki.archlinux.org/index.php/PKGBUILD#makedepends

ridobe commented on 2019-07-27 00:29

A new version has been posted with Ryzen 3000 support.