Package Details: zeal-git 0.6.1.r112.g51ae407-1

Git Clone URL: https://aur.archlinux.org/zeal-git.git (read-only, click to copy)
Package Base: zeal-git
Description: A simple documentation browser
Upstream URL: https://zealdocs.org/
Keywords: api dash docs docset documentation offline
Licenses: GPL3
Conflicts: zeal
Submitter: 5long
Maintainer: trollixx
Last Packager: trollixx
Votes: 68
Popularity: 0.000030
First Submitted: 2013-06-29 09:47
Last Updated: 2020-02-07 03:52

Pinned Comments

trollixx commented on 2017-09-07 18:38

Please do not flag package out of date, unless it doesn't build. It's a Git package, the version is computed during the installation.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

kmicu commented on 2014-07-31 19:03

+1 for skipping libappindicator, which is probably needed only for Unity users, by default.

mazzolino commented on 2014-07-28 11:34

@5long, can you please fix the package? I think adding the CONFIG option for skipping the libappindicator dependency would be the right thing, as many people might not want to have mono as an additional dependency.

nickl commented on 2014-07-17 08:04

Re libappindicator, you can just add "CONFIG+=no_libappindicator" to the qmake line to remove the dependency.

PR is here: https://github.com/jkozera/zeal/pull/173

rafi commented on 2014-07-15 14:14

`libappindicator`? why? now that wants `mono` damnet :(

Driadan commented on 2014-06-30 10:45

libappindicator is now a requirement to build

After installing it, zeal builded fine

kmicu commented on 2014-06-20 16:13

In file included from main.cpp:1:0:
mainwindow.h:17:43: fatal error: libappindicator/app-indicator.h: No such file or directory
#include <libappindicator/app-indicator.h>
^
compilation terminated.
Makefile:606: recipe for target 'main.o' failed
make: *** [main.o] Error 1

ffuugoo commented on 2014-05-10 12:27

Guys, how about updating PKGBUILD version from time to time?
I am a (retardet =_=) user of Zeal for smth like half a year or even more...
And as PKGBUILD has fixed version num I thought it's dead in development and didn't upgrade it all this time. That's a real issue.

philpirj commented on 2014-03-24 17:16

arch=('i686', 'x86_64')
should not have a comma:
arch=('i686' 'x86_64')

Why it's flagged out of date? It's being taken from git.

johntyree commented on 2014-03-17 18:28

This builds fine but is too broken to use.

QEventLoop: Cannot be used without QApplication
"Qt Warning - invalid keysym: dead_actute"
QSystemTrayIcon::setVisible: No Icon set
libpng warning: iCCP: Not recognizing known sRGB profile that has been edited

Anonymous comment on 2013-09-08 16:03

This causes me an error:
==> ERROR: zeal-git is not available for the 'i686' architecture.
Note that many packages may need a line added to their PKGBUILD
such as arch=('i686').
The build failed.
---
To fix it change "arch" from: ('i686', 'x86_64') to: ('any') in the PKGBUILD file.