Package Details: zeal-git 0.6.1.r112.g51ae407-1

Git Clone URL: https://aur.archlinux.org/zeal-git.git (read-only, click to copy)
Package Base: zeal-git
Description: A simple documentation browser
Upstream URL: https://zealdocs.org/
Keywords: api dash docs docset documentation offline
Licenses: GPL3
Conflicts: zeal
Submitter: 5long
Maintainer: trollixx
Last Packager: trollixx
Votes: 68
Popularity: 0.000030
First Submitted: 2013-06-29 09:47
Last Updated: 2020-02-07 03:52

Pinned Comments

trollixx commented on 2017-09-07 18:38

Please do not flag package out of date, unless it doesn't build. It's a Git package, the version is computed during the installation.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

chaopeng commented on 2015-01-12 15:09

fix for The folder structure has changed the zeal directory is changed to src so there is an error on PKGBUILD: line 27

build() {
- cd ${srcdir}/${_appname}/${_appname}
+ cd ${srcdir}/${_appname}
qmake PREFIX=/usr CONFIG+=no_libappindicator
make
}

package() {
- cd ${srcdir}/${_appname}/${_appname}
+ cd ${srcdir}/${_appname}
make INSTALL_ROOT="$pkgdir" install
}

chaopeng commented on 2015-01-12 15:08

fix for The folder structure has changed the zeal directory is changed to src so there is an error on PKGBUILD: line 27

build() {
- cd ${srcdir}/${_appname}/${_appname}
+ cd ${srcdir}/${_appname}
qmake PREFIX=/usr CONFIG+=no_libappindicator
make
}

package() {
- cd ${srcdir}/${_appname}/${_appname}
+ cd ${srcdir}/${_appname}
make INSTALL_ROOT="$pkgdir" install
}

Anonymous comment on 2015-01-12 10:03

The folder structure has changed the zeal directory is changed to src so there is an error on PKGBUILD: line 27

trollixx commented on 2015-01-06 02:49

@FrenchToasts, thanks for reporting the problem. I have submitted the fixed PKGBUILD.

FrenchToasts commented on 2015-01-06 01:46

There is an error while parsing the PKGBUILD:
==> ERROR: arch contains invalid characters: ','

It doesn't seem to like that there is a comma on this line: arch=('i686', 'x86_64')

To temporarily fix the issue, I changed the above line to:

arch=('x86_64')

Anonymous comment on 2014-11-03 12:06

Build fails for me with the error message, that it is not buidable for i686.

Spoffy commented on 2014-10-19 13:40

+1 for the "CONFIG+=no_libappindicator" option. The build worked fine for me after that.

emlcj commented on 2014-09-16 05:13

+1 working well with adding "CONFIG+=no_libappindicator" in PKG qmake line

rafi commented on 2014-08-17 12:29

+1 for skipping libappindicator. it's a black hole.

herrecito commented on 2014-08-07 11:12

Built successfully with qmake-qt5 "CONFIG+=no_libappindicator" and arch=('i686' 'x86_64').