Package Details: zathura-git 0.4.5.28.g3b4540f-2

Git Clone URL: https://aur.archlinux.org/zathura-git.git (read-only, click to copy)
Package Base: zathura-git
Description: a document viewer
Upstream URL: http://pwmt.org/projects/zathura
Licenses: custom
Conflicts: zathura
Provides: zathura
Submitter: None
Maintainer: mlq
Last Packager: mlq
Votes: 90
Popularity: 0.000710
First Submitted: 2009-09-19 13:00
Last Updated: 2020-03-27 17:42

Dependencies (14)

Required by (8)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

mlq commented on 2013-08-22 09:26

You need to (re)install girara-gtk2-git or a more current version of girara. The error message says it all.

timofonic commented on 2013-08-22 03:32

==> Starting build()...
zathura build options:
CFLAGS = -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -std=c99 -pedantic -Wall -Wno-format-zero-length -Wextra -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
LIBS = -lgirara-gtk2 -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfreetype -lfontconfig -lgthread-2.0 -pthread -lglib-2.0 -lgmodule-2.0 -pthread -lglib-2.0 -lpthread -lm -lsqlite3 -lmagic
DFLAGS = -g
CC = cc
Makefile:47: *** "The minimum required version of girara is 0.1.6". Stop.
==> ERROR: A failure occurred in build().


Why?

haawda commented on 2012-04-25 22:02

florianbw is right with his suggestion. But why posting it three times? :)

archman commented on 2012-04-25 09:08

mlq:

http://pastebin.com/nk5Ggw01

archman commented on 2012-04-25 08:40

mlq:

http://pastebin.com/nk5Ggw01

florianbw commented on 2012-04-24 15:08

Can you add a

provides="zathura"

so it does not exit w/ the following error:

:: zathura-git and zathura are in conflict. Remove zathura? [y/N] Y
error: failed to prepare transaction (could not satisfy dependencies)
:: zathura-djvu: requires zathura
:: zathura-pdf-poppler: requires zathura
:: zathura-ps: requires zathura?

Thanks!

florianbw commented on 2012-04-24 15:08

Can you add a

provides="zathura"

so it does not exit w/ the following error:

:: zathura-git and zathura are in conflict. Remove zathura? [y/N] Y
error: failed to prepare transaction (could not satisfy dependencies)
:: zathura-djvu: requires zathura
:: zathura-pdf-poppler: requires zathura
:: zathura-ps: requires zathura?

Thanks!

florianbw commented on 2012-04-24 15:07

Can you add a

provides="zathura"

so it does not exit w/ the following error:

:: zathura-git and zathura are in conflict. Remove zathura? [y/N] Y
error: failed to prepare transaction (could not satisfy dependencies)
:: zathura-djvu: requires zathura
:: zathura-pdf-poppler: requires zathura
:: zathura-ps: requires zathura?

Thanks!

mlq commented on 2012-04-23 11:37

Since your email does not work: Can you create a gdb backtrace?

archman commented on 2012-04-23 09:10

Segfaults when searching through the file:

Just 'Segmentation fault' is echoed.
Using the latest git release for both zathura and all the plugins/dependencies.
Size of pdf is 44.9 MiB.