Package Details: zam-plugins-git 3.10.r55.gf2d73e5-1

Git Clone URL: https://aur.archlinux.org/zam-plugins-git.git (read-only)
Package Base: zam-plugins-git
Description: Collection of LV2/LADSPA/VST audio plugins for high quality processing.
Upstream URL: https://github.com/zamaudio/zam-plugins
Licenses: GPL2
Conflicts: zam-plugins, zamplugins
Provides: zam-plugins
Submitter: cocreature
Maintainer: CrocoDuck
Last Packager: CrocoDuck
Votes: 13
Popularity: 0.96
First Submitted: 2014-10-07 09:21
Last Updated: 2019-02-16 17:34

Latest Comments

dvzrv commented on 2019-02-13 13:48

@CrocoDuck: Please use jack as dependency, as jack2 provides jack.

sekret commented on 2019-01-13 15:09

I also absolutely vote for not updating the PKGBUILD if it's not required. Please only update it for real changes that are required for it to still compile.

People who use the AUR have to take care of working builds themselves, e.g. in case they stop working because of soname changes etc. There are tools who help with this, e.g. aurebuildcheck. So this also isn't a reason to update the PKGBUILD.

What I find reasonable however is to update the PKGBUILD as soon as version 3.11 of zam-plugins get released. But please not after every commit or once a week or something like that.

CrocoDuck commented on 2018-10-21 16:05

@SpotlightKid, to ensure that the PKGBUILD still works. Also, it seems to me that people that use AUR helpers will have the update automatically.

SpotlightKid commented on 2018-10-21 15:53

Why are you updating the PKGBUILD when only the revision of the sources change? That's not necessary for VCS packages.

funkmuscle commented on 2018-02-20 01:10

yep I spoke to Damien and he said that ZamChild670 was disabled as he hated to sound of it.

CrocoDuck commented on 2018-02-19 21:03

@funkmuscle ZamChild670, ZamNoise, ZamSFZ and ZamSynth are all included in the source code, but they are not listed in the make file PLUGINS list. As such, they are not built. See the make file at the upstream url:

https://github.com/zamaudio/zam-plugins/blob/master/Makefile

ZamSFZ and ZamSynth can be appended to the PLUGINS list ant apparently the software builds, but ZamChild670 and ZamNoise will instead fail due to missing UI code. I would assume that the developers removed these plugins for a reason, maybe just temporarily.

funkmuscle commented on 2018-02-18 17:17

hey you guys seeing the ZamChild670 plugin in the batch?

cocreature commented on 2015-08-19 19:30

@Artefact2
Updated, it builds for me now.

Artefact2 commented on 2015-08-19 08:57

Needs `git submodule init` and `git submodule update` or else it won't compile due to missing sources.