Package Details: yubico-piv-tool 2.1.0-2

Git Clone URL: https://aur.archlinux.org/yubico-piv-tool.git (read-only, click to copy)
Package Base: yubico-piv-tool
Description: Tool to interact with the PIV applet on a YubiKey NEO
Upstream URL: https://developers.yubico.com/yubico-piv-tool/
Licenses: GPL3
Submitter: travisghansen
Maintainer: travisghansen
Last Packager: travisghansen
Votes: 22
Popularity: 0.002923
First Submitted: 2014-12-29 06:34
Last Updated: 2020-07-12 22:46

Latest Comments

1 2 Next › Last »

DDoSolitary commented on 2020-07-12 17:01

Missing build dependency: cmake

erikryverling commented on 2020-03-06 08:55

@travisghansen Ah! Sorry. I missed that. Thanks.

travisghansen commented on 2020-02-21 17:15

@erikryverling I don't see a new release. Regarding the key see the earlier comments about importing the ID.

erikryverling commented on 2020-02-21 07:02

yubico-piv-tool-2.0.0.tar.gz ... FAILED (unknown public key 1B21578FC4686BFE)

JohnMaguire commented on 2018-10-26 14:30

@travisghansen Working great, thanks!

travisghansen commented on 2018-10-25 21:17

@JohnMaguire I've updated the PKGBUILD and changed the dep to be just openssl instead of openssl-1.0. Let me know how that works for ya..

JohnMaguire commented on 2018-10-25 14:10

@travisghansen In the past month or so, I believe coinciding with an OpenSSL upgrade, I stopped being able to add Yubikeys to ssh-agent via libykcs11.so.

It seems that Yubico has added support for OpenSSL 1.1.1, and linking against OpenSSL 1.0.2 was causing issues for me. I was able to get a working build by:

a) Downloading the PKGBUILD
b) Removing PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
c) Running makepkg -s

Step (c) still did not produce a working build if I had artifacts from a previous build, before step (b).

grawity commented on 2018-08-14 06:29

Missing makedepends: gengetopt and help2man

breitj commented on 2018-08-13 17:41

Hi,

the build fails on my system with the following message:

"/build/yubico-piv-tool/src/yubico-piv-tool-1.6.0/build-aux/missing: line 81: gengetopt: command not found"

If I manually install the package 'gengetopt', it builds successfully. Could you please add that package to the dependencies? Also, thanks for maintaining this package. :)

rtfm3514 commented on 2017-12-10 17:08

Hi,

thanks for maintaining this package.

Could you add "armv7h" to the supported architectures, please? The package builds and works fine on my Raspberry Pi 2/3.

Thanks a lot, rtfm3514