Package Details: ytop 0.6.2-2

Git Clone URL: https://aur.archlinux.org/ytop.git (read-only, click to copy)
Package Base: ytop
Description: A TUI system monitor written in Rust
Upstream URL: https://github.com/cjbassi/ytop
Licenses: MIT
Conflicts: ytop
Provides: ytop
Submitter: cjbassi
Maintainer: cjbassi
Last Packager: cjbassi
Votes: 19
Popularity: 1.81
First Submitted: 2020-01-13 22:16
Last Updated: 2020-05-25 16:27

Required by (0)

Sources (1)

Latest Comments

caleb commented on 2020-05-03 18:22

@grondinm If you (or anyone reading this) don't want to install a Rust toolchain to your user account like that you can use rust instead of rustup to provide the build dependency. It will give you a bit older set of tools but it is fully pre-packaged ready to use and for this and many other projects it should work fine.

grondinm commented on 2020-05-03 17:57

@caleb

You are correct. After doing

rustup install stable

rustup default stable

package builds fine. Pardon my ignorance.

caleb commented on 2020-05-03 17:43

@grondinm This package builds fine, your Rust toolchain isn't complete. There are multiple wayn to fulfill the cargo dependency required to make this. Depending on which one you chose to use you may need to prepare your environment. Some of the options are prebuilt packages with batteries included. Others are a wrapper used to update a toolchain, but you have to run the right command to install a working Rust toolchain to your user account. Once you have that should build fine.

grondinm commented on 2020-05-03 08:56

Unable to install this.

Ends with

==> Validating source files with sha256sums... ytop-0.6.0.tar.gz ... Passed ==> Extracting sources... -> Extracting ytop-0.6.0.tar.gz with bsdtar ==> Starting build()... error: no default toolchain configured ==> ERROR: A failure occurred in build().