Package Details: ytmdesktop 1.13.0-5

Git Clone URL: https://aur.archlinux.org/ytmdesktop.git (read-only, click to copy)
Package Base: ytmdesktop
Description: A desktop app for YouTube Music
Upstream URL: https://ytmdesktop.app
Licenses: CC0 1.0 Universal
Submitter: yochananmarqos
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 4
Popularity: 0.24
First Submitted: 2020-06-21 02:06
Last Updated: 2021-04-06 20:48

Dependencies (6)

Required by (0)

Sources (3)

Latest Comments

1 2 Next › Last »

yochananmarqos commented on 2021-01-05 18:57

@dcunningham: Fixed.

dcunningham commented on 2021-01-05 17:12

@yochananmarqos sha256sum for ytmdesktop.sh might need updating:

==> Making package: ytmdesktop 1.13.0-3 (Tue 05 Jan 2021 11:07:40 AM CST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading ytmdesktop-1.13.0.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   130    0   130    0     0    427      0 --:--:-- --:--:-- --:--:--   427
100  612k    0  612k    0     0   778k      0 --:--:-- --:--:-- --:--:-- 6377k
  -> Found ytmdesktop.sh
  -> Found ytmdesktop.desktop
==> Validating source files with sha256sums...
    ytmdesktop-1.13.0.tar.gz ... Passed
    ytmdesktop.sh ... FAILED
    ytmdesktop.desktop ... Passed
==> ERROR: One or more files did not pass the validity check!

yochananmarqos commented on 2021-01-05 17:04

@eatmyvenom: I reverted to Electron 10 for now.

eatmyvenom commented on 2021-01-05 05:50

@yochananmarqos ive reproduced it in a fresh container and a friend managed to reproduce it as well. The flags way I make it is makepkg -srcf --skipinteg --noconfirm if that helps you. Also I don't have npm or yarn installed before making the package and no global electron installation via npm.

yochananmarqos commented on 2021-01-05 03:14

@eatmyvenom: Yes, the project uses Electron 10, but 11 works just fine. No idea what's different on your end, but I can't reproduce the error.

eatmyvenom commented on 2021-01-04 23:08

When building, npm outputs this:

downloading url=https://github.com/electron/electron/releases/download/v10.1.5/electron-v10.1.5-linux-x64.zip

Which causes this error upon running

App threw an error during load                                                  
Error: The module '/tmp/.org.chromium.Chromium.SuEBe8'                          
was compiled against a different Node.js version using                          
NODE_MODULE_VERSION 82. This version of Node.js requires                        
NODE_MODULE_VERSION 85. Please try re-compiling or re-installing                
the module

Normally I would assume something went wrong with the build process, however when checking the upstream package.json it shows electron 10 as the required version for building. Therefore the only 2 solutions to this problem are to either change the ytmdesktop.desktop file to use electron10, or get the upstream to move to electron 11.

yochananmarqos commented on 2021-01-04 16:10

@eatmyvenom: It works fine with Electron 11. Do not flag packages out of date unless there's a new release.

eatmyvenom commented on 2021-01-04 09:04

This package doesnt work at the moment, if anyone else is getting errors upon attempting to launch then do this:

  • Install the electron10 package

  • Edit /usr/share/applications/ytmdesktop.desktop to use electron10 instead of electron

  • Enjoy

dustovich commented on 2020-11-17 17:05

Hello, I am trying to get this built and it comes up with the following errors. Is there something I am doing wrong? The git version comes up with the same error eventually.

==> Starting build()...

> electron@10.1.1 postinstall /data/build/ytmdesktop/src/ytmdesktop-1.13.0/node_modules/electron
> node install.js

Error: EACCES: permission denied, mkdir '/home/dxxto/.cache/electron/httpsgithub.comelectronelectronreleasesdownloadv10.1.1SHASUMS256.txt'
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @nodert-win10/windows.media@^0.2.96 (node_modules/@nodert-win10/windows.media):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @nodert-win10/windows.media@0.2.96: wanted {"os":"win32","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @nodert-win10/windows.media.playback@^0.2.96 (node_modules/@nodert-win10/windows.media.playback):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @nodert-win10/windows.media.playback@0.2.96: wanted {"os":"win32","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @nodert-win10/windows.storage.streams@^0.2.96 (node_modules/@nodert-win10/windows.storage.streams):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @nodert-win10/windows.storage.streams@0.2.96: wanted {"os":"win32","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @nodert-win10/windows.foundation@^0.2.96 (node_modules/@nodert-win10/windows.foundation):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @nodert-win10/windows.foundation@0.2.96: wanted {"os":"win32","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN discord-rpc@3.1.3 requires a peer of register-scheme@github:devsnek/node-register-scheme but none is installed. You must install peer dependencies yourself.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! electron@10.1.1 postinstall: `node install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the electron@10.1.1 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /data/build/ytmdesktop/src/npm-cache/_logs/2020-11-17T14_04_16_691Z-debug.log
==> ERROR: A failure occurred in build().
    Aborting...

I could upload the full log somewhere if needed.

I also posted this upstream, don't know if this is arch specific or not.

Can someone help. Thanks.

crborga commented on 2020-09-23 16:25

Thank you so much because we shouldn't have to use these universal app platforms.