Package Details: yle-dl 20211213-1

Git Clone URL: https://aur.archlinux.org/yle-dl.git (read-only, click to copy)
Package Base: yle-dl
Description: Download video and audio from YLE Areena.
Upstream URL: http://aajanki.github.io/yle-dl/
Keywords: areena yle
Licenses: GPL3
Submitter: Huulivoide
Maintainer: ZaZam (Huulivoide)
Last Packager: ZaZam
Votes: 33
Popularity: 0.81
First Submitted: 2012-04-15 18:12
Last Updated: 2021-12-13 18:52

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

iipe commented on 2015-10-01 09:10

I would like a working version too.

The old YLE Areena (v3) is still available and the current yle-dl version works with that (using rtmpdump) but so far hasn't worked with the new Areena.

Mikaela commented on 2015-10-01 07:40

I am also on the latest version and it's not working for me either.

```
% yle-dl snipp
yle-dl 2.8.1: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2015 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv2
Subtitles saved to snip.fin.srt
Subtitles saved to snip.swe.srt
Output file: snip.flv
PHP Warning: Module 'curl' already loaded in Unknown on line 0

KSV Adobe HDS Downloader

You have to install and enable the following extension(s) to continue: 'mcrypt'
Subtitles saved to snip.fin.srt
Subtitles saved to snip.swe.srt
Failed to import youtube_dl
```

Installing php-mcrypt (potentially missing depedency in PKGBUILD?) and youtube-dl changed nothing.

Anonymous comment on 2015-09-26 07:54

I updated the yle-dl for latest 2.8.1-1 version and it doesn't work at all. There is an error message: Failed to import youtube_dl.

Also the rtmp-backend is broken, when I trying use the option --protocol rtmp, I get following error message: The following protocols are not supported on this source: rtmp

ahjolinna commented on 2015-09-19 04:01

plz update or disown the pkgs if u wont/cant

dlandau commented on 2015-05-30 17:56

Please update PKGBUILD, old version doesn't work at all and current upstream does.

schalox commented on 2015-04-30 18:19

Update to 2.7.0: http://sprunge.us/eMXS

Huulivoide commented on 2015-02-05 12:22

bcmat is an official extension provided in the
php package itself. But must be enabled in php.ini
or by passing '-d extension=bcmath.so' to php.

All should be fixed now.

mokkurkalve commented on 2015-02-05 12:08

Also; yle-dl homepage states the following:
"AdobeHDS.php additionally requires php and the following php extensions: bcmath, curl and SimpleXML."
The extensions does not appear satisfied.
php ./AdobeHDS.php
KSV Adobe HDS Downloader
You have to install the following extension(s) to continue: 'bcmath'

I don't find packages for these extensions in official packages or AUR.
Am I looking in the wrong places?

mokkurkalve commented on 2015-02-05 11:50

I get error on md5sum here. This is the file downloaded:
a7dcf3b7d3c6330bbe7b1df1ee99caa1 AdobeHDS.php

ahjolinna commented on 2015-02-02 17:53

@Huulivoide: why did u remove the line that would install AdobeHDS.php ?