Package Details: yle-dl 20200222-1

Git Clone URL: (read-only, click to copy)
Package Base: yle-dl
Description: Download video and audio from YLE Areena.
Upstream URL:
Keywords: areena yle
Licenses: GPL3
Submitter: Huulivoide
Maintainer: ZaZam (Huulivoide)
Last Packager: ZaZam
Votes: 31
Popularity: 0.38
First Submitted: 2012-04-15 18:12
Last Updated: 2020-02-29 07:08

Latest Comments

1 2 3 4 5 Next › Last »

membend commented on 2019-10-17 15:56

Works with python-attrs-19.3.0-1

ZaZam commented on 2019-10-13 10:07

@Wild_Penguin yle-dl seems to work fine with the latest attrs, I added a patch to allow it.

Wild_Penguin commented on 2019-10-12 16:10

There is no python-attrs<19.2.0 in AUR nor Arch repositories.

ZaZam commented on 2019-03-23 08:58


I tried and yle-dl works with 19.1, but needs to be changed to allow it. I added a patch.

miasma commented on 2019-03-16 04:25

:: installing python-attrs (19.1.0-1) breaks dependency 'python-attrs<18.3.0' required by yle-dl

Python-attrs was updated again. I tried and it requires changes on the code level. So much for

ZaZam commented on 2019-01-26 14:22

I also think that the 'provides' and 'conflicts' fields are completely unnecessary on this package. It is enough for the other packages that provide yle-dl to have these fields. I made the PKGBUILD simpler and removed these.

I added a patch to allow newer configargparse versions as yle-dl seems to work fine with the latest one. The same patch is in git, so it can be removed when the next version is released.

ReekyMarko commented on 2019-01-17 09:54

@Huulivoide It does not conflict with itself, it just conflicts with other packages that provide yle-dl.

ReekyMarko commented on 2019-01-17 09:53

python-configargparse got updated in community and it broke yle-dl for me. Downgrading it to 0.13.0-2 from 0.14.0-1 fixed it.

Huulivoide commented on 2019-01-12 10:14

A package should not conflict with it self. That makes no sense what so ever.

sumt commented on 2018-09-14 12:04

Next version depends on python-attrs >= 18.1.0, < 18.3.0. @ZaZam I added you as a co-maintainer. Feel free to keep this PKGBUILD up-to-date if I'm not quick enough :)