Package Details: yggdrasil 0.3.11-1

Git Clone URL: https://aur.archlinux.org/yggdrasil.git (read-only)
Package Base: yggdrasil
Description: An experiment in scalable routing as an encrypted IPv6 overlay network
Upstream URL: https://github.com/yggdrasil-network/yggdrasil-go
Keywords: decentralized decentralized-internet e2e-encryption ipv6 mesh mesh-networks routing-algorithm routing-mesh spanning-tree
Licenses: LGPLv3
Conflicts: yggdrasil-git
Submitter: luzifer
Maintainer: luzifer
Last Packager: luzifer
Votes: 3
Popularity: 0.30
First Submitted: 2018-12-08 17:30
Last Updated: 2019-10-25 09:01

Dependencies (1)

Required by (1)

Sources (2)

Latest Comments

luzifer commented on 2019-09-04 21:33

I fear that means Go 1.13 landed in the Arch repo, the Go team changed how Go modules works (again) and the build is broken now until an upstream fix within Yggdrasil. :(

I've already reported that one and I hope a new release will follow soon: https://github.com/yggdrasil-network/yggdrasil-go/issues/535

pl_m commented on 2019-09-04 21:23

I'm sorry for stupid question, but what does this error mean(?)

==> Extracting sources...
  -> Extracting yggdrasil-0.3.8.tar.gz with bsdtar
==> Starting build()...
Building: yggdrasil
go: github.com/hjson/hjson-go@v0.0.0-20181010104306-a25ecf6bd222: invalid pseudo-version: does not match version-control timestamp (2018-12-10T17:43:06Z)
==> ERROR: A failure occurred in build().
    Aborting...

there is a mension of "invalid pseudo-version" on https://golang.org/doc/go1.13 -- but what the best way to fix this? (I'm not a go-programmer unfortunatly)

makeworld commented on 2019-02-19 02:32

The yggdrasil.conf file should not be installed so that it can be globally read. chmod 600 should be run or something.

whoami commented on 2018-12-27 04:10

https://github.com/yggdrasil-network/yggdrasil-go/releases/tag/v0.3.2