Package Details: yay 9.4.2-1

Git Clone URL: https://aur.archlinux.org/yay.git (read-only)
Package Base: yay
Description: Yet another yogurt. Pacman wrapper and AUR helper written in go.
Upstream URL: https://github.com/Jguer/yay
Keywords: arm AUR go helper pacman wrapper x86
Licenses: GPL
Submitter: jguer
Maintainer: jguer
Last Packager: jguer
Votes: 858
Popularity: 70.29
First Submitted: 2016-10-05 17:20
Last Updated: 2019-10-23 12:05

Required by (8)

Sources (1)

Pinned Comments

jguer commented on 2019-10-23 08:36

Having issues upgrading yay and pacman at the same time? Here is the proposed workaround for now.

yay -S yay-bin
sudo pacman -Syu
yay -S yay

yay-bin is a binary ready package with yay already compiled against v5.2, it does not require go to build. https://github.com/Jguer/yay/issues/1084

jguer commented on 2019-04-16 14:08

I cannot delete the spam comments appearing regularly in this page, which has also led me to disable notifications from here. I remind that the best way to receive support or report a problem is through the Upstream URL.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

psltn commented on 2019-11-03 02:13

@f1she3: No need to. Read the "Note" here: https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

f1she3 commented on 2019-11-02 23:56

Hi !

I think that fakeroot (https://www.archlinux.org/packages/core/x86_64/fakeroot/) should be added as a dependency, am I wrong ?

waasl commented on 2019-10-28 09:58

@test $test test test [script]test[/script] [code]test[/code] test 'test' "test"

test

//test / test /

test

brando56894 commented on 2019-10-26 21:10

looking for conflicting packages... error: failed to prepare transaction (could not satisfy dependencies) :: installing pacman (5.2.0-2) breaks dependency 'pacman<=5.1.3' required by yay

jguer commented on 2019-10-25 10:48

@gdude2002 you sure your pacman cache was not symlinked? I have only seen this in those cases. The only other reason for that to happen is for pacman to be set as a dependency instead of an explicit, which yay does not do.

gdude2002 commented on 2019-10-25 10:43

@jguer Just to let you know that trying to do that (install yay-bin then update as normal with pacman) ended up actually removing pacman from my system for some reason - luckily the dependencies were still there so I could manually copy the files in from a manually downloaded copy from the package repos, and now everything is fine.

soloturn commented on 2019-10-24 23:07

if one does not like binary packages, copied from https://www.reddit.com/r/archlinux/comments/dlpng7/cant_pacman_syu_because_of_yay/

yay -G yay #clones new yay from git
yay -R yay #removes old yay
sudo pacman -Syu
cd yay/
makepkg -si #install the yay you cloned

dgmulf commented on 2019-10-24 20:25

Is anyone else getting problems with the diff functionality in 9.4.2? When upgrading a package, the diff behaves as if every version is an initial commit, e.g.:

diff --git /home/dgmulf/build/aur/st/PKGBUILD /home/dgmulf/build/aur/st/PKGBUILD
new file mode 100644
index 0000000..7ad8f2e
--- /dev/null
+++ /home/dgmulf/build/aur/st/PKGBUILD
[...]

Jake commented on 2019-10-23 19:17

Is it really necessary to put the specific pacman version in the dependency list? It might be not totally clean, but can't you just expect that it is built with the current versions from the official repo? Then yay would as usual upgrade from the offical repos first, build the AUR stuff afterwards and everything would be fine.

Also if we are really strict, if yay-bin is compiled against v5.2 (libalpm.so.12) it will also not run with 5.1.x. So it should also depend on pacman>=5.2, or not? If you fix this that workaround would also not work.

wooptoo commented on 2019-10-23 17:16

@jguer Another method is to fetch the latest yay PKGBUILD yay -G yay, update pacman, then build the new yay with makepkg.