Package Details: yay-bin 9.4.2-2

Git Clone URL: https://aur.archlinux.org/yay-bin.git (read-only)
Package Base: yay-bin
Description: Yet another yogurt. Pacman wrapper and AUR helper written in go. Pre-compiled.
Upstream URL: https://github.com/Jguer/yay
Keywords: AUR go helper pacman wrapper
Licenses: GPL
Conflicts: yay
Provides: yay
Submitter: jguer
Maintainer: jguer
Last Packager: jguer
Votes: 83
Popularity: 8.02
First Submitted: 2016-12-03 15:06
Last Updated: 2019-10-24 02:04

Required by (8)

Sources (3)

Pinned Comments

jguer commented on 2019-10-23 08:31

Having issues updating yay and pacman at the same time?

yay -S yay-bin

sudo pacman -Syu

https://github.com/Jguer/yay/issues/1084

Latest Comments

jguer commented on 2019-10-24 02:05

ARM packages have been readded now that pacman 5.2 has reached core in archlinux arm

jguer commented on 2019-10-23 08:31

Having issues updating yay and pacman at the same time?

yay -S yay-bin

sudo pacman -Syu

https://github.com/Jguer/yay/issues/1084

jguer commented on 2019-10-23 08:16

Yes, I just saw this and this is something that may require manual action. yay 9.3.3 is preventing you from installing it because it breaks current deps, I'll be looking at the easiest upgrade path.

Archlinux ARM still doesn't have pacman 5.2 in its repositories, once it's added I'll add arm back to the PKGBUILD

bjo commented on 2019-10-23 08:13

No support for armv7h any more?

CWRau commented on 2019-10-23 08:11

Removing the dependency helped, kinda

Now I could install yay-bin, but without the dependency to pacman>5.2 I couldn't run yay again, I had to manually pacman -S pacman

CWRau commented on 2019-10-23 07:59

I cannot update this package, it errors with the following message:

λ yay -S yay-bin
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo: 1]  pacman-5.2.0-2
[Aur: 1]  yay-bin-9.4.0-1

  1 yay-bin                                  (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: PKGBUILD up to date, Skipping (1/1): yay-bin
  1 yay-bin                                  (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: Parsing SRCINFO (1/1): yay-bin
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (5.2.0-2) breaks dependency 'pacman<=5.1.3' required by yay-bin
Error installing repo packages

jguer commented on 2019-06-21 12:16

That's true, should be all good now

bjo commented on 2019-06-21 10:02

You'll have to update the PKGBUILD because the sha1sum doesn't fit any more

jguer commented on 2019-06-21 09:49

I've renamed the directory inside of the tarball manually so it should be fixed, I won't be updating the PKGBUILD but the build process to fix this

LChris314 commented on 2019-06-20 14:23

On an armv7h machine it fails to build with the following error:

install: cannot stat '/home/alarm/.cache/yay/yay-bin/src/yay_9.2.1_armv7h/yay': No such file or directory

This is because yay_x.y.z_armv7h.tar.gz extracts to a directory named yay_x.y.z_armv7l. A quick fix made to the PKGBUILD would suffice, though renaming the directory inside the tarball might be more consistent.