Package Details: yakyak 1.5.4-1

Git Clone URL: https://aur.archlinux.org/yakyak.git (read-only)
Package Base: yakyak
Description: Desktop client for Google Hangouts
Upstream URL: https://github.com/yakyak/yakyak
Licenses: MIT
Submitter: kuenx
Maintainer: mistachie777 (RobertFischer, vincedyne, snowiow)
Last Packager: mistachie777
Votes: 46
Popularity: 0.031263
First Submitted: 2015-06-23 17:25
Last Updated: 2019-07-02 21:51

Dependencies (4)

Required by (0)

Sources (3)

Pinned Comments

kuenx commented on 2016-12-02 14:03

BEFORE FLAGGING OUT-OF-DATE:
Please don't flag this package as out-of-date if the new release is a pre-release. YakYak creates pre-releases for testing with the same release version as the final release will have, which would cause problems with the package SHA sums and break the package if I published them. The pre-releases have the "pre-release" badge on GitHub. Wait for the final release before flagging.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

mistachie777 commented on 2019-07-01 19:12

EDIT: Disregard the previous comment about switching to electron 4 not working - it was fine after a reboot. I have made the requested changes (switching dependency to electron 4, and editing yakyak.sh to use electron 4 to launch YakYak) and everything works correctly for me.

I don't know what the long term future of this program is now that Hangouts is supposed to disappear by October. If the developers don't plan to support the new Hangouts Meet/Chat programs, then this package will become obsolete. I will try to keep it working as long as it still useful!

ejstacey commented on 2019-06-30 23:48

The electron package has upgraded to v5. Yak Yak doesn't seem to work with it, even after a rebuild. The main screen won't show. When my system upgraded to the latest version of electron, it also installed an electron4 package.

To make this app work, you can edit yakyak.sh before building this package and change 'electron' to 'electron4'. Alternatively, you can edit /usr/bin/yakyak and change 'electron' to 'electron4'.

Both these solutions are not great until the actual source file gets updated, but editing the source file and rebuilding the package is better. Since you're building without checking integrity already, it shouldn't complain.

kachunkachunk commented on 2019-03-11 04:46

As a workaround for those trying to install, you can pass along arguments to ignore the validity (integrity) check, at your own risk (well, beyond the obvious with AUR):

Trizen: trizen -S --skipinteg yakyak

Yaourt: yaourt --m-arg "--skipinteg" -S yakyak

Yay: yay -S --mflags --skipinteg yakyak

kuenx commented on 2019-02-26 10:34

Yeah, that's the issue I addressed in my pinned comment. Yakyak doesn't have deterministic pre-releases. They re-release pre-releases under the same version number multiple times until the final release, and thus the checksums change and the package breaks.

To avoid this problem it'd be better to only publish final releases in this package. The package version says "1.5.4" but this hasn't been released yet. It's actually using the "1.5.4-beta-rolling" pre-release. 1.5.3 is the current final release.

stramaz commented on 2019-02-26 10:24

I cannot install it. yakyak-1.5.4-beta-rolling.tar.gz not passes the validation source file...

==> Validating source files with sha256sums... yakyak-1.5.4-beta-rolling.tar.gz ... FAILED yakyak.desktop ... Passed yakyak.sh ... Passed ==> ERROR: One or more files did not pass the validity check! :: Unable to build yakyak - makepkg exited with code: 1

mistachie777 commented on 2018-12-14 22:42

@codedmart As far as I know, Electron apps package all of their resources, including their icons, to maintain cross-platform consistency. So there shouldn't be any dependency on your system icons, for example.

Since you're seeing this with the binary release as well, the only thing I can think of right now is something to do with your display forcing the icons in the app into a size they don't allow. Are you running a HiDPI display? You could also try adjusting the zoom. I did try messing with the zoom and could not break the icons, so I'm not sure that's the issue either.

I would recommend opening an issue with screenshots on the YakYak Github page: https://github.com/yakyak/yakyak/issues. Hopefully the developers have some ideas!

codedmart commented on 2018-12-11 22:49

@mistachie777 Hmm... same problem with the binary. I wonder if it is an issue with icons on my machine if no one else has this issue.

mistachie777 commented on 2018-12-11 20:28

@codedmart, can you try running the binary release (https://github.com/yakyak/yakyak/releases/download/v1.5.4-beta-rolling/yakyak-1.5.4-linux-x64.tar.gz) and see if you still have the icon problems? If the icons still don't work correctly then that would indicate a problem with YakYak itself. If the icons do work, then there could be an issue with the package.

codedmart commented on 2018-12-11 14:06

I posted this question 9 months or so ago, but never got an answer. I still have this issue:

I am having issue with icons in the app? I only see text so rather then the three bars for the menu I see menu in big text? Or rather then the + in the add a new conversation circle I see ad in big text? Am I missing something?

simona commented on 2018-12-11 12:17

now ok. perfect :-)))