Package Details: yakyak-git v1.2.0.r1161.gb11ca58-1

Git Clone URL: https://aur.archlinux.org/yakyak-git.git (read-only, click to copy)
Package Base: yakyak-git
Description: Desktop client for Google Hangouts
Upstream URL: https://github.com/yakyak/yakyak
Licenses: MIT
Conflicts: yakyak
Provides: yakyak
Submitter: itsizzy
Maintainer: mpento
Last Packager: mpento
Votes: 8
Popularity: 0.000003
First Submitted: 2015-09-09 15:11
Last Updated: 2020-08-06 19:28

Latest Comments

1 2 3 Next › Last »

mpento commented on 2020-08-06 19:29

Update to v1.2.0.r1161.gb11ca58

becatlibra commented on 2020-04-07 18:49

It appears that the version is showing as the same, post install. I tried fully uninstalling and reinstalling and it appears the same

[14:46:27]# yay -Ss yakyak
aur/yakyak-git v1.5.5.r1070.g3afc470-1 (+8 0.00%) (Installed: v1.2.0.r1070.g3afc470-1)
    Desktop client for Google Hangouts

Some details from during the install process

==> Validating source files with sha256sums...
    yakyak ... Skipped
    yakyak.desktop ... Passed
==> Validating source_x86_64 files with sha256sums...
    electron-v8.0.0-linux-x64.zip ... Passed
==> Making package: yakyak-git v1.5.5.r1070.g3afc470-1 (Tue 07 Apr 2020 02:45:28 PM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating yakyak git repo...
Fetching origin
  -> Found yakyak.desktop
  -> Found electron-v8.0.0-linux-x64.zip
==> Validating source files with sha256sums...
    yakyak ... Skipped
    yakyak.desktop ... Passed
==> Validating source_x86_64 files with sha256sums...
    electron-v8.0.0-linux-x64.zip ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of yakyak git repo...
Cloning into 'yakyak'...
done.
Switched to a new branch 'makepkg'
==> Starting prepare()...
Archive:  electron-v8.0.0-linux-x64.zip

... skipping the inflating messages

==> Starting pkgver()...
==> Updated version: yakyak-git v1.2.0.r1070.g3afc470-1
==> Sources are ready.
==> Making package: yakyak-git v1.2.0.r1070.g3afc470-1 (Tue 07 Apr 2020 02:45:33 PM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...

mpento commented on 2020-04-05 16:58

Update to v1.5.5, electron v8.0.0

mpento commented on 2020-03-07 22:46

Updated to v1.2.0.r1070.g3afc470

mpento commented on 2019-06-23 20:36

Updated electron dependency to 4.1.4 to clean up startup issue with JavaScript.

mpento commented on 2018-10-02 17:43

@RobertFischer: Looking into this now.

RobertFischer commented on 2018-10-02 14:49

@mpento -- I built just now and am getting the same issue as @artemklevtsov.

  • which coffee => /home/robert/.npm/bin/coffee
  • coffee --version => CoffeeScript version 2.3.2
  • node --version => v10.11.0
  • npm --version => 6.4.1
  • gulp --version => CLI version 3.9.1
  • node-gyp --version => v3.8.0

There's a huge number of build errors from validation.cc and its included files (including header files within V8), and then it finally ends with this message:

make: *** [validation.target.mk:103: Release/obj.target/validation/src/validation.o] Error 1
make: Leaving directory '/tmp/makepkg/yakyak-git/src/yakyak/node_modules/utf-8-validate/build'
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/node-gyp/lib/build.js:262:23)
gyp ERR! stack     at ChildProcess.emit (events.js:182:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:240:12)
gyp ERR! System Linux 4.18.10-arch1-1-ARCH
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /tmp/makepkg/yakyak-git/src/yakyak/node_modules/utf-8-validate
gyp ERR! node -v v10.11.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok 
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 (node_modules/bufferutil):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 install: `node-gyp rebuild`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: utf-8-validate@1.1.0 (node_modules/utf-8-validate):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: utf-8-validate@1.1.0 install: `node-gyp rebuild`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

audited 3748 packages in 5.448s
found 84 vulnerabilities (16 low, 44 moderate, 23 high, 1 critical)
  run `npm audit fix` to fix them, or `npm audit` for details

> yakyak@1.5.1 gulp /tmp/makepkg/yakyak-git/src/yakyak
> gulp

[10:44:11] Failed to load external module coffeescript/register
[10:44:11] Requiring external module coffee-script/register
gulp[27875]: ../src/node_contextify.cc:628:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x55e6af39ebc1 node::Abort() [gulp]
 2: 0x55e6af39ecbb  [gulp]
 3: 0x55e6af3d4b6b node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [gulp]
 4: 0x55e6af601def  [gulp]
 5: 0x55e6af6024df  [gulp]
 6: 0x19c48c15c01d 
/opt/aur/yakyak-git/PKGBUILD: line 44: 27864 Aborted                 (core dumped) npm run gulp

Let me know if there's anything that I can do to help debug this issue.

mpento commented on 2018-08-15 16:13

Updated to latest (r916) and bumped pkgrel

mpento commented on 2018-07-09 11:50

@artemklevtsov: I cannot reproduce this issue, but, I have seen it in the past.

What is the output of the following from inside src/yakyak:

npm ls coffeescript

You should see something like this:

~/Downloads/yakyak-git/src/yakyak -> npm ls coffeescript
yakyak@1.5.1 /home/drwho/Downloads/yakyak-git/src/yakyak
└─┬ gulp-coffee@3.0.2
  └── coffeescript@2.3.1

If not, try:

npm install coffeescript

And then run gulp again and see if it works.

artemklevtsov commented on 2018-07-07 13:22

Can't build:

> yakyak@1.5.1 gulp /tmp/trizen-unikum/yakyak-git/src/yakyak
> gulp

[20:21:21] Failed to load external module coffeescript/register
[20:21:21] Requiring external module coffee-script/register
gulp[18561]: ../src/node_contextify.cc:631:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x55c713a013e1 node::Abort() [gulp]
 2: 0x55c713a014eb  [gulp]
 3: 0x55c713a32864 node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [gulp]
 4: 0x55c713c2f44f  [gulp]
 5: 0x55c713c2fb4f  [gulp]
 6: 0x3c20a47041bd