Package Details: yacreader 9.6.2-2

Git Clone URL: https://aur.archlinux.org/yacreader.git (read-only, click to copy)
Package Base: yacreader
Description: Comic reader for cross-platform reading and managing your digital comic collection.
Upstream URL: http://www.yacreader.com
Keywords: cbr cbz comic pdf reader
Licenses: GPL3
Conflicts: yacreader-bin, yacreader-git, yacreaderlibraryserver-standalone
Submitter: selmf
Maintainer: selmf
Last Packager: selmf
Votes: 28
Popularity: 0.74
First Submitted: 2014-07-06 15:35
Last Updated: 2019-10-04 11:53

Latest Comments

1 2 3 4 Next › Last »

selmf commented on 2020-01-12 08:35

@jamesburg your libpdfium-nojs package is built against an older version of the icu package. Rebuild it and it should work again.

jamesburg commented on 2020-01-12 04:43

I'm getting these errors when I try to build and install:

/usr/bin/ld: warning: libicuuc.so.64, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libpdfium.so, not found (try using -rpath or -rpath-link)

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libpdfium.so: undefined reference to `u_isalnum_64'

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libpdfium.so: undefined reference to `u_isalpha_64'

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libpdfium.so: undefined reference to `u_isspace_64'

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libpdfium.so: undefined reference to `u_tolower_64'

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libpdfium.so: undefined reference to `u_toupper_64'

collect2: error: ld returned 1 exit status

Anonymous comment on 2020-01-11 06:16

Thank you very much!

archont commented on 2019-10-04 13:06

Download, build, install: everything working fine. Thank you very much!

selmf commented on 2019-10-04 11:58

Sorry for the broken upload. YACReader switched to using CI and the "extension" is a build stamp. Having this popping up in a stable source tarball and contaminating paths isn't exactly optimal, so there probably is room for improvement and I think the next versions will use a scheme that is more compatible with packaging and semantic version. For now I have implemented a solution close to @saturn_knights suggestion (thanks!). Let me know if this still gives you trouble.

saturn_knight commented on 2019-10-04 09:15

Yes, the version numbering has changed and the generated URL is no longer valid. The 1909283 extension is not part of the folder path, so it will need to be moved to another variable. e.g.

pkgver=9.6.2
_pkgext=1909283
source=( "https://github.com/YACReader/yacreader/releases/download/${pkgver}/yacreader-${pkgver}.${_pkgext}-src.tar.xz")

archont commented on 2019-10-04 08:53

Github adress seems to be invalid

dramm commented on 2019-09-11 13:59

Ok, I will keep using libpdfium-nojs then, thanks again!

selmf commented on 2019-09-11 05:04

libpdfium-nojs provides libpdfium, libpdfium-bin is outdated to the point that it is dangerous (pdf is a very popular attack vector) and uses a different install directory structure, so it is incompatible. A libpdfium package never existed. I intended to create one at a point, but for YACReader it is pointless. We use pdfium to render comic pages somewhat faster than poppler, so we have no use for javascript in the pdf library anyways and not having it is one security risk less.

dramm commented on 2019-09-10 19:15

Yeah, it was my system. I'm compiling it right now. Thanks!

PS: libpdfium is no longer a package, maybe switch to libpdfium-nojs or libpdfium-bin?