Package Details: xorgxrdp 0.2.14-1

Git Clone URL: https://aur.archlinux.org/xorgxrdp.git (read-only, click to copy)
Package Base: xorgxrdp
Description: Xorg drivers for xrdp
Upstream URL: https://github.com/neutrinolabs/xorgxrdp
Licenses: MIT
Submitter: Chocobo1
Maintainer: Chocobo1
Last Packager: Chocobo1
Votes: 3
Popularity: 0.67
First Submitted: 2018-02-06 14:30
Last Updated: 2020-08-31 05:06

Latest Comments

1 2 Next › Last »

lateparty commented on 2020-10-25 06:23

note, I ran "gpg --keyserver keys.gnupg.net --recv-keys 61ECEABBF2BB40E3A35DF30A9F72CDBC01BF10EB" for it to work for 0.2.14-1 (2020-08-31 15:06)

dgy18787 commented on 2020-08-31 06:57

for those see the error about gpg keys, you can try this: gpg --keyserver keys.gnupg.net --recv-keys 03993B4065E7193B

the developer had sign the package with his/her own key, which can refer to: https://github.com/neutrinolabs/xrdp/issues/1627

alpha7024 commented on 2020-07-31 21:08

gpg --recv-keys 9F72CDBC01BF10EB

results in "gpg: keyserver receive failed: General error"

Lrs121 commented on 2019-06-26 21:40

For those perplexed by the signature check, which is used by some AUR packages, use the following command. Bypassing the signature check is poor practice and not recommended.

gpg --recv-keys PUBLICKEYSTRING

Replace the PUBLICKEYSTRING with the reported public key for the package you are building. In this case use 9F72CDBC01BF10EB

firewyre commented on 2019-02-21 01:45

Similar issue as Plexcon's :(

yaourt -S xorgxrdp

==> Verifying source file signatures with gpg... xorgxrdp-0.2.9.tar.gz ... FAILED (unknown public key 9F72CDBC01BF10EB) ==> ERROR: One or more PGP signatures could not be verified! ==> ERROR: Makepkg was unable to build xorgxrdp.

But, there's hope!

I verified the contents of what's downloaded myself, and was able to use yaourt --m-arg "--skippgpcheck" -S xorgxrdp to install successfully.

moxin commented on 2019-01-01 11:24

same issue as Plexcon posted

Plexcon commented on 2018-12-31 18:56

sudo pacman-key --recv 9F72CDBC01BF10EB ==> ERROR: Could not verify any of the PGP signatures!

sigbjorn commented on 2018-05-27 14:51

For anyone that ended up here:

I succeeded making a local fix, first produce the patch file to fix the offending construct, then modify the build section in PKGBUILD file to patch the source prior to the make command. Then rerun makepkg, and sudo pacman -U etc.

PKGBUILD:

build() { cd "xorgxrdp"

./bootstrap ./configure --prefix="/usr" patch xrdpdev/xrdpdev.c ../../xrdpdev.patch make }

<hr>

The patch file (that might be valid in cases where XvExtensions are not defined): xrdpdev.patch--- --- ../xorgxrdp-git/src/xorgxrdp-0.2.6/xrdpdev/xrdpdev.c 2017-08-09 06:45:44.000000000 +0200 +++ src/xorgxrdp/xrdpdev/xrdpdev.c 2018-05-27 11:31:51.676870106 +0200 @@ -468,7 +468,7 @@ / try to init simd functions / rdpSimdInit(pScreen, pScrn);

-#if defined(XvExtension) && XvExtension +#if defined(XvExtension) / XVideo / if (!rdpXvInit(pScreen, pScrn)) {

<hr>

lnicola commented on 2018-05-20 13:35

https://github.com/neutrinolabs/xorgxrdp/issues/119

lnicola commented on 2018-05-20 13:15

This doesn't build:

xrdpdev.c: In function ‘rdpScreenInit’: xrdpdev.c:471:40: error: operator '&&' has no right operand #if defined(XvExtension) && XvExtension ^ make[2]: *** [Makefile:457: xrdpdev.lo] Error 1