Package Details: xorg-server-devel-git 1.20.0.r578.g49456e0a3-1

Git Clone URL: https://aur.archlinux.org/xorg-server-git.git (read-only, click to copy)
Package Base: xorg-server-git
Description: Development files for the X.Org X server (git version)
Upstream URL: https://gitlab.freedesktop.org/xorg/xserver.git
Keywords: git x-server xorg xorg-server
Licenses: custom
Groups: xorg
Conflicts: xorg-server-devel
Provides: xorg-server-devel
Submitter: ilikenwf
Maintainer: JstKddng
Last Packager: JstKddng
Votes: 45
Popularity: 0.98
First Submitted: 2008-08-07 19:05
Last Updated: 2020-01-11 15:22

Required by (98)

Sources (3)

Pinned Comments

JstKddng commented on 2019-12-24 02:48

Hello, new maintainer here. I made the least possible modifications in order to have this compile again. And thanks to @goddessfreya for the patch. I think that patch will be removed soon as upstream will fix this issue at one point.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

JstKddng commented on 2019-12-24 02:50

@goddessfreya

I see it differently, I have my PKGBUILDS as close as upstream and only modify tiny bits to achieve what I want, I have less maintenance hassle that way, lets give that to the arch maintainers. :P

JstKddng commented on 2019-12-24 02:48

Hello, new maintainer here. I made the least possible modifications in order to have this compile again. And thanks to @goddessfreya for the patch. I think that patch will be removed soon as upstream will fix this issue at one point.

goddessfreya commented on 2019-12-24 00:23

I've mentioned this before, but I keep a maintained PKGBUILD here: https://github.com/goddessfreya/gabs/blob/master/builtins/xorg-server-git-gentz/PKGBUILD

The packages aren't split, but I personally don't care. It struck me as a maintenance hassle that I didn't want to put up with given the number of *-gentz packages I maintain.

The build failures are due to the recent XWayalnd refactor. I git bisected it a couple days ago, and the first bad commit was 89e32d00f6e03fcdab267bfd9f0b0c5c2747d380. You need to apply https://gitlab.freedesktop.org/xorg/xserver/merge_requests/367.patch to get it to build.

JstKddng commented on 2019-12-23 23:11

@yurikoles

I'm sorry to hear that, don't worry though, I'll continue your legacy. Will push an update once I finish some work.

yurikoles commented on 2019-12-23 15:50

I can’t maintain it now due to health difficulties.

Rodolpheh commented on 2019-12-22 10:45

libdmx has been removed from official repos and can't be found in AUR (it is supposedly unused or obsolete). As such, we can't build xorg-server-git anymore. Removing the dependency to libdmx lead to another error : ../xserver/hw/xwayland/xwayland-glamor-eglstream.c:500:37: error: implicit declaration of function « xwl_window_from_window » [-Werror=implicit-function-declaration]

haagch commented on 2019-10-31 11:33

btw: I need the --libdir=lib parameter for meson.

Without it, for example the modules get installed into fakeinstall/usr/lib/x86_64-linux-gnu/xorg/modules/ instead of fakeinstall/usr/lib/xorg/modules/

axtor commented on 2019-10-27 16:28

@hagabaka

Downgrade libglvnd to 1.1.1-1 and mesa to 19.1.7.

It is convenient to use the downgrade script: https://aur.archlinux.org/packages/downgrade.

yurikoles commented on 2019-10-19 07:34

@hagabaka it's upstream issue https://gitlab.freedesktop.org/xorg/xserver/issues/914

hagabaka commented on 2019-10-18 21:50

I'm getting the following error. Any idea how to fix it?

In file included from /usr/include/EGL/eglplatform.h:122,
                 from /usr/include/epoxy/egl_generated.h:11,
                 from /usr/include/epoxy/egl.h:46,
                 from ../xserver/glamor/glamor_priv.h:43,
                 from ../xserver/hw/kdrive/ephyr/ephyr_glamor_xv.c:31:
/usr/include/X11/Xlib.h:222:2: error: conflicting types for ‘GC’
  222 | *GC;
      |  ^~
In file included from ../xserver/hw/kdrive/ephyr/../src/kdrive.h:36,
                 from ../xserver/hw/kdrive/ephyr/ephyr_glamor_xv.c:28:
../xserver/include/gcstruct.h:282:3: note: previous declaration of ‘GC’ was here
  282 | } GC;
      |   ^~
[317/814] Compiling C object 'Xext/02e353f@@libxserver_xext@sta/sync.c.o'.
ninja: build stopped: subcommand failed.