Package Details: xorg-server-bug865 1.20.7-1

Git Clone URL: https://aur.archlinux.org/xorg-server-bug865.git (read-only, click to copy)
Package Base: xorg-server-bug865
Description: Xorg X server with the patch for freedesktop bug 865 (need to kick hotkeys on release, not press)
Upstream URL: https://xorg.freedesktop.org
Licenses: custom
Groups: xorg
Conflicts: glamor-egl, nvidia-utils<=331.20, xf86-video-modesetting, xorg-server
Provides: X-ABI-EXTENSION_VERSION=10.0, X-ABI-VIDEODRV_VERSION=24.0, X-ABI-XINPUT_VERSION=24.1, x-server, xorg-server=1.20.7
Replaces: glamor-egl, xf86-video-modesetting
Submitter: kyak
Maintainer: kyak
Last Packager: kyak
Votes: 38
Popularity: 0.20
First Submitted: 2012-03-13 18:20
Last Updated: 2020-03-28 14:49

Dependencies (43)

Required by (180)

Sources (8)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 Next › Last »

kyak commented on 2015-01-07 12:06

You might need to do one or both of the following:

1) gpg --keyserver pgp.mit.edu --recv-keys 310180050905E40C

2) Add line "keyring /etc/pacman.d/gnupg/pubring.gpg" to your ~/.gnupg/gpg.conf

alexzk commented on 2015-01-07 11:12

alex@moy-super:/var/abs/local/xorg-server$ sudo pacman-key -r 310180050905E40C
gpg: key 0905E40C: "Julien Cristau <julien.cristau@ens-lyon.org>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
==> Updating trust database...
gpg: next trustdb check due at 2016-01-22
alex@moy-super:/var/abs/local/xorg-server$ sudo pacman-key --lsign-key 310180050905E40C
-> Locally signing key 310180050905E40C...
==> ERROR: 310180050905E40C could not be locally signed.
alex@moy-super:/var/abs/local/xorg-server$

kyak commented on 2015-01-05 21:40

pacman-key -r 310180050905E40C

FiX commented on 2015-01-05 20:42

xorg-server-1.16.3.tar.bz2 ... FAILED (unknown public key 310180050905E40C)

kyak commented on 2014-12-29 17:56

Updated to 1.16.3-2

kyak commented on 2014-12-21 07:00

Updated to 1.16.3

kyak commented on 2014-12-12 16:40

Updated to 1.16.2.901

kyak commented on 2014-11-12 13:28

Updated to 1.16.2

kyak commented on 2014-10-27 08:57

The package has been updated according to Darko's comments. Sorry for the delay!

hybroid commented on 2014-10-20 15:27

Hi! Please fix PKGBUILD for providing version of the "xorg-server". Without thhis packages (like "catalyst-test") are trying to install original "xorg-server", with drop this package..

--- PKGBUILD.orig 2014-10-20 18:16:40.201111175 +0300
+++ PKGBUILD 2014-10-20 18:18:05.377777264 +0300
@@ -97,7 +97,7 @@
depends=(libepoxy libxdmcp libxfont libpciaccess libdrm pixman libgcrypt libxau xorg-server-common xf86-input-evdev libxshmfence libgl)
# see xorg-server-*/hw/xfree86/common/xf86Module.h for ABI versions - we provide major numbers that drivers can depend on
# and /usr/lib/pkgconfig/xorg-server.pc in xorg-server-devel pkg
- provides=('X-ABI-VIDEODRV_VERSION=18' 'X-ABI-XINPUT_VERSION=21' 'X-ABI-EXTENSION_VERSION=8.0' 'x-server' 'xorg-server')
+ provides=('X-ABI-VIDEODRV_VERSION=18' 'X-ABI-XINPUT_VERSION=21' 'X-ABI-EXTENSION_VERSION=8.0' 'x-server' 'xorg-server=1.16.1')
groups=('xorg')
conflicts=('nvidia-utils<=331.20' 'glamor-egl' 'xorg-server')
replaces=('glamor-egl')