Package Details: xojo 2017r1-3

Git Clone URL: https://aur.archlinux.org/xojo.git (read-only, click to copy)
Package Base: xojo
Description: A RAD environment based on BASIC that compiles native applications for Windows, Mac, Linux, the web and now with 64Bit and ARM V2 (Raspberry Pi 2) support.
Upstream URL: http://www.xojo.com
Licenses: custom
Submitter: Schala
Maintainer: twphoenix1982
Last Packager: twphoenix1982
Votes: 6
Popularity: 0.000000
First Submitted: 2013-07-08 05:38
Last Updated: 2017-03-29 19:41

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

twphoenix1982 commented on 2015-10-06 09:15

So. Quick Fix is online to get xojo working again.

twphoenix1982 commented on 2015-10-05 08:49

I'll look into it later today or tomorrow. have to work first.

perhaps i'll create an aur package with ncurses 5 installed for compatibile with ncurses 6. installed

As a Quick workaround you can create an Symlink manually.
ln -s /usr/lib32/libncursesw.so.6.0 /usr/lib32/libncurses.so.5
after this Xojo should be working again.

pattisahusiwa commented on 2015-10-04 22:37

Xojo requires lib32-ncurses v5 (libncurses.so.5) to work, but current version of lib32-ncurses is 6.0. How to fix it without downgrade lib32-ncurses?

twphoenix1982 commented on 2015-08-19 10:06

So.
new pkgrel.

Temporary removed the (make)dependency on lib32-webkitgtk2. Till i find an replacement or recreate the Package

Know this: the compiled apps (running on arch) will not beable to use the HTMLViewer Component.

twphoenix1982 commented on 2015-08-19 01:00

Yes. It is only for the HTMLViewer in the Compiled Apps.

But i look into it.

ngoonee commented on 2015-08-19 00:47

Yeah well, AUR shakeup. Latest xojo builds without it, at least, not sure if support for anything would be missing in that case. Perhaps the browser component won't work (but its a makedep, so something needs updating anyway).

twphoenix1982 commented on 2015-08-19 00:43

I'll look into it.

Didn't know that, it is not activly maintained.

ngoonee commented on 2015-08-19 00:37

One of the dependencies of this package was deleted from the AUR in the cleanup,
lib32-webkitgtk2.

As its required for this package, you should consider maintaining it as well.

twphoenix1982 commented on 2015-08-18 22:59

Update to Xojo 2015 R2.4

- fixed an ICU Bug on Some Linux OS Systems

twphoenix1982 commented on 2015-08-12 07:46

So. Updated to the new point Release.

Witch fixes some very annoying bugs (xojo cloud uploader for example)