Package Details: xnviewmp-system-libs 0.95-1

Git Clone URL: https://aur.archlinux.org/xnviewmp-system-libs.git (read-only, click to copy)
Package Base: xnviewmp-system-libs
Description: An efficient multimedia viewer, browser and converter (using system libraries).
Upstream URL: http://www.xnview.com/en/xnviewmp/
Keywords: graphics
Licenses: custom
Conflicts: xnviewmp
Submitter: Corax
Maintainer: Corax
Last Packager: Corax
Votes: 16
Popularity: 0.85
First Submitted: 2017-01-21 15:31
Last Updated: 2020-02-04 23:01

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

Corax commented on 2017-10-03 23:10

@Marcouney: very good point, thanks for pointing that out! In fact, I originally intended to use all the directories in /usr/lib/qt/plugins/, but I couldn't do that because including xcbglintegrations/ was crashing XnView (and still does, unfortunately). So instead I replaced the lib directories provided in xnviewmp/lib with symlinks into the system directories. But clearly, even though it is not provided with XnView, styles/ is a directory that can be useful and doesn't crash XnView, so it should be added.

I have pushed 0.87-2, which does this additional symlink. I wonder, should I modify xnview.sh to only set QT_QPA_PLATFORMTHEME if it is not already set? That would make the lives of people using qt5ct easier, I guess.

Marcouney commented on 2017-09-22 15:00

qt5ct seems to work if one adds a symbolic link to /usr/lib/qt/plugins/styles in /opt/xnviewmp/lib/.

Corax commented on 2017-08-02 18:08

@waldbaer59: it's great to hear that, thanks for your feedback!

waldbaer59 commented on 2017-08-02 04:20

As far as I can see all works like it should. Even better: when Gimp is loaded via xnviewmp, the G'mic plugins don't crash, as it happens with the 'normal' xnviewmp due to qt-version conflicts.

Corax commented on 2017-04-27 21:44

I managed to remove more libraries (everything in lib/, basically), I haven't tested it thoroughly so if you notice new problems please come back to me.

Corax commented on 2017-02-05 23:52

@whoseos You're welcome, glad this solution works for you too! If you remember the crash I mentioned previously, it was due to qt.conf being absent, it works for me as long as it is there, even if it is empty... So I left it there unmodified, nobody has complained so far so I take it as a good sign :-)

whoseos commented on 2017-02-04 11:13

Works very nicely on a recently renewed plasma desktop install. Thanks for your efforts, Corax!

DungeonMaster commented on 2017-01-22 22:03

Just a hint for those who might be experiencing problems with QT_QPA_PLATFORMTHEME=qt5ct I downloaded a package in the AUR called qt5gtk2 and I use QT_QPA_PLATFORMTHEME=qt5gtk

qt5gtk is explained well in this article:

http://dglava.github.io/en/qtplatform-style.html

Corax commented on 2017-01-22 00:59

Glad it works for you, and thanks for the feedback :-)

Maniaxx commented on 2017-01-21 18:44

Seems to work properly here. Thank you.