Package Details: xmobar-git 0.36.r24.ga071c2a-1

Git Clone URL: https://aur.archlinux.org/xmobar-git.git (read-only, click to copy)
Package Base: xmobar-git
Description: Minimalistic Text Based Status Bar
Upstream URL: https://hackage.haskell.org/package/xmobar
Licenses: custom:BSD3
Conflicts: xmobar
Provides: xmobar
Submitter: cgirard
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 19
Popularity: 1.13
First Submitted: 2010-12-22 09:40
Last Updated: 2020-11-20 00:41

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Anonymous comment on 2011-12-31 16:40

Yeah, I had the same problem. Many of the haskell packages are outdated. After I had build a good version of haskell-text, haskell-dbus-core was still outdated and to install dependencies for that, you have to have the old haskell-text...since I did not want to change every single pkgbuild of all those damn dependencies, I just stuck with normal xmobar...

pdxleif commented on 2011-12-28 06:54

Cofiguration fails with:
Setup: At least the following dependencies are missing:
dbus-core >=0.9.2.1, text >=0.11.1.5 && <0.12

haskell-text has been flagged out of date in extra last month. The one in the Haskell Platform that just came out is recent enough. Maybe I could try checking out a slightly older version from the git repo, else build my own updated version of haskell-text?

cgirard commented on 2011-10-21 16:22

Why? No. It's the way this has to be handled. But it seems you should fill a bug against clyde.

Anonymous comment on 2011-10-21 15:35

I see cgirard. Should these be removed from the dependency list then?

cgirard commented on 2011-10-21 15:32

They are provided by GHC.

Anonymous comment on 2011-10-21 15:23

haskell-filepath and haskell-time cannot be resolved according to clyde.

Anonymous comment on 2011-09-22 19:59

Fyi libxrandr is now a dependency

cgirard commented on 2011-08-28 10:20

Thanks.
Package updated. Please be aware that haskell-libmpd, haskell-alsa-core, haskell-timezone-olson and haskell-timezone-series are outdated. Blame arch-haskell team...

pdxleif commented on 2011-08-27 19:42

Also, haskell-timezone-olson is now a dependency.

pdxleif commented on 2011-08-27 19:32

The haskell-libmpd-git dependency can be switched back to just haskell-libmpd - it's been upgraded.