Package Details: xmobar-git 0.36.r24.ga071c2a-1

Git Clone URL: https://aur.archlinux.org/xmobar-git.git (read-only, click to copy)
Package Base: xmobar-git
Description: Minimalistic Text Based Status Bar
Upstream URL: https://hackage.haskell.org/package/xmobar
Licenses: custom:BSD3
Conflicts: xmobar
Provides: xmobar
Submitter: cgirard
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 19
Popularity: 1.13
First Submitted: 2010-12-22 09:40
Last Updated: 2020-11-20 00:41

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

tlunter commented on 2014-02-11 18:38

Looks like this now needs a requirement for haskell-http due to https://github.com/jaor/xmobar/commit/7a4219abe3b4885820bece194c7f125274a711c6#diff-2ef1a34f72bcbd28050f41e97edc1206

fosskers commented on 2013-06-24 05:33

There you go!

jachymb commented on 2013-06-23 14:45

Please add haskell-regex-compat as a dependency.

fosskers commented on 2013-04-06 03:36

Fixed! Builds with the new pacman now too.

Anonymous comment on 2013-04-05 01:07

It's not causing any problem in particular, but packages should generally be installed to /usr as far as I know. Just wanted to point that out after I was surprised to see my /usr/local being populated.

fosskers commented on 2013-04-04 21:55

Thanks for pointing that out. It must be a leftover from when I inherited this package. Is that causing problems?

Anonymous comment on 2013-04-04 12:59

Is there any reason why this package installs to /usr/local by default? I see '--prefix=/usr' in the all_extensions line but not in the default setup.

Anonymous comment on 2013-03-10 03:47

Thank you fosskers.
I'll try reinstalling haskell*

fosskers commented on 2013-03-09 06:17

Hey Axl. I'm not having any build problems over here... maybe try reinstalling haskell-x11 and haskell-x11-xtf?

Anonymous comment on 2013-03-08 07:38

I can't build it even with the default PKGBULD.
Are there more requirements needed for X11?

==> xmobar-git dependencies:
- wireless_tools (already installed)
- gmp (already installed)
- libxml2 (already installed)
- libxrandr (already installed)
- libxinerama (already installed)
- libxft (already installed)
- ghc (already installed)
- haskell-x11 (already installed)
- haskell-x11-xft (already installed)
- haskell-mtl (already installed)
- haskell-parsec (already installed)
- haskell-stm (already installed)
- haskell-utf8-string (already installed)
- libxrandr (already installed)
- wireless_tools (already installed)
- git (already installed)
--------------------------------------- cut --------------------------------------------------------------------------
==> Starting make...
Cloning into '/tmp/yaourt-tmp-atm/aur-xmobar-git/src/xmobar-build'...
done.
Configuring xmobar-0.16...
Setup: At least the following dependencies are missing:
X11 >=1.6.1
==> ERROR: A failure occurred in build().
Aborting...