Package Details: xmind 3.7.8+8update8-1

Git Clone URL: https://aur.archlinux.org/xmind.git (read-only)
Package Base: xmind
Description: Brainstorming and Mind Mapping Software
Upstream URL: http://www.xmind.net
Licenses: LGPL, EPL
Submitter: arojas
Maintainer: yechs
Last Packager: RemiliaForever
Votes: 21
Popularity: 0.600085
First Submitted: 2017-07-06 19:05
Last Updated: 2018-08-13 09:19

Latest Comments

1 2 3 4 Next › Last »

shui commented on 2019-05-08 08:28

谢谢,看了teacher4711的评论,正常使用中

remak commented on 2019-03-07 07:14

Thanks. With java-10-openjdk works correct.

weearc commented on 2019-02-05 16:56

please remove line --add-modules=java.se.ee

teacher4711 commented on 2019-01-27 09:11

OpenJDK8 works for me, too. Added this line at the beginning of XMind.ini, as recommended by @maoxuner:

-vm /usr/lib/jvm/java-8-openjdk/bin

and commented out the last line with a '#', which @user_serge recommended.

--add-modules=java.se.ee

farfoodyou commented on 2019-01-26 08:15

If you needn't jdk11, you can change default java enviroment.

sudo pacman -S jdk10-openjdk

archlinux-java status

sudo archlinux-java set jdk-10-openjdk

It works for me.

maoxuner commented on 2019-01-10 16:42

Module java.se.ee was removed from java11

https://openjdk.java.net/jeps/320

https://jaxenter.com/jdk-11-java-ee-modules-140674.html

So it ends up in errors with option --add-modules=java.se.ee


There are 2 choices to handle the problem:

  1. Remove option --add-modules=java.se.ee However it crashed again with java version openjdk version "11.0.1" 2018-10-16

  2. Install the package jdk10-openjdk and change the vm for xmind http://forum.ubuntu.org.cn/viewtopic.php?t=487719 Edit /usr/share/xmind/XMind/XMind.ini and insert these two lines to the head of the file (remember to delete the empty line)

-vm

/usr/lib/jvm/java-10-openjdk/bin

The second choice works well with my laptop

user_serge commented on 2018-10-05 13:16

I removed "--add-modules=java.se.ee" in /usr/share/xmind/XMind/XMind.ini and it XMind started nice and easy.

reefland commented on 2018-08-26 13:58

Tried deleting the ~/.xmind directory which frequently works. Didn't work this time. My info:

$ pacman -Q xmind
xmind 3.7.8+8update8-1

$ java -version
openjdk version "1.8.0_181"
OpenJDK Runtime Environment (build 1.8.0_181-b13)
OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)

$ XMind
Unrecognized option: --add-modules=java.se.ee
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Gtk-Message: 09:34:59.111: GtkDialog mapped without a transient parent. This
is discouraged.

Had to edit /usr/share/xmind/XMind/XMind.ini and remove "--add-modules=java.se.ee" line. Once I did that XMind started right up.

StratosL commented on 2018-08-16 18:36

Thinking of creating a package for Xmind Zen?

methril commented on 2018-04-26 14:05

This module should not be versioned as version 8.7 instead of 3.7.7?