Package Details: xidel-git r575.d56b00b-1

Git Clone URL: https://aur.archlinux.org/xidel-git.git (read-only, click to copy)
Package Base: xidel-git
Description: XQuery/XPath/CSS/JSONiq engine and webscraper
Upstream URL: http://www.videlibri.de/xidel.html
Licenses: GPL
Conflicts: xidel
Provides: xidel
Submitter: leuko
Maintainer: leuko
Last Packager: leuko
Votes: 0
Popularity: 0.000000
First Submitted: 2020-11-16 15:23
Last Updated: 2020-11-16 15:28

Latest Comments

carlosal1015 commented on 2022-01-08 18:36

Hi, I have the following message error:

==> Making package: xidel-git r666.a933a99-1 (Sat 08 Jan 2022 01:35:10 PM -05)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
-- Building...
Free Pascal Compiler version 3.2.2 [2021/05/31] for x86_64
Copyright (c) 1993-2021 by Florian Klaempfl and others
Target OS: Linux for x86-64
Compiling xidel.pas
Compiling ./internettools/internet/internetaccess.pas
Compiling ./internettools/data/bbutils.pas
bbutils.pas(1060,15) Warning: Symbol "strDecodeUTF8Character" is deprecated: "Use (pchar,pchar) overload or strIterator."
bbutils.pas(5890,13) Warning: Symbol "strEncodeHex" is deprecated
Compiling ./internettools/data/bbutilsbeta.pas
Compiling ./internettools/data/bbrandomnumbergenerator.pas
internetaccess.pas(1566,29) Warning: Symbol "existsConnection" is deprecated
Compiling ./internettools/internet/multipagetemplate.pas
Compiling ./internettools/data/extendedhtmlparser.pas
Compiling ./internettools/data/simplehtmltreeparser.pas
Compiling ./internettools/data/simplehtmlparser.pas
Compiling ./internettools/data/htmlinformation.pas
Compiling ./internettools/data/simplehtmltreeparser.pas
Compiling ./internettools/data/xquery.namespaces.pas
Compiling ./internettools/data/xquery.internals.common.pas
xquery.internals.common.pas(434,80) Fatal: Can't find unit PasDblStrUtils used by xquery.internals.common
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode
==> ERROR: A failure occurred in build().

leuko commented on 2021-01-29 22:13

I did not try dear chovy. This package compiles the latest version from the repo.

chovy commented on 2021-01-29 21:10

does this support v0.9.9?