Package Details: xfce4-screensaver 0.1.4-2

Git Clone URL: https://aur.archlinux.org/xfce4-screensaver.git (read-only)
Package Base: xfce4-screensaver
Description: Screensaver for XFCE Desktop
Upstream URL: https://www.xfce.org
Licenses: GPL
Groups: xfce4
Submitter: r3pek
Maintainer: r3pek
Last Packager: r3pek
Votes: 16
Popularity: 3.470474
First Submitted: 2018-10-15 23:19
Last Updated: 2019-03-25 20:13

Latest Comments

Vanilline commented on 2019-07-15 18:57

https://git.xfce.org/apps/xfce4-screensaver/snapshot/xfce4-screensaver-0.1.6.tar.gz

lectrode commented on 2019-06-14 21:44

@acutbal garcon-gtk3 is a Manjaro-specific package. When installing this, you need to edit the PKGBUILD and either remove the garcon dependency, or change it to garcon-gtk3.

This is alpha-quality software and should only be installed if you know what you're doing. If you're just looking for a screensaver program for Manjaro Xfce, try xscreensaver. If you need help, search the manjaro forum and post there if necessary.

acutbal commented on 2019-06-14 09:20

Hi!! It fails to build with Manjaro 18.0.4, seems to be a problem with garcon-gtk3: https://imgur.com/EuYUNhV

Regards!! :)

r3pek commented on 2019-03-25 16:45

@SolarAquarion Didn't actually check. Thx for the info, will fix it later today.

SolarAquarion commented on 2019-03-25 16:35

mate-screensaver, and gnome-screensaver no longer conflicts with xfce4 screensaver

Alad commented on 2019-01-11 04:43

Fails to build without exo

TomaszGasior commented on 2018-11-02 23:43

Please add libxxf86misc to dependencies. Without it xfce4-screensaver fails.

Update: if you have libxxf86misc package installed during xfce4-screensaver compilation, xfce4-screensaver requires libxxf86misc and crashes without it. If you compile xfce4-screensaver without libxxf86misc in operating system, it's not needed.

loganmarchione commented on 2018-10-31 00:34

Is there a dependency on gnome-session for this? I'm getting this error when running 'xfce4-screensaver'
(xfce4-screensaver:1726): WARNING : 20:29:53.903: Failed to get session presence proxy: Could not get owner of name 'org.gnome.SessionManager': no such name

r3pek commented on 2018-10-23 23:29

Thanks @andreyv for your comments! Just updated the PKGBUILD with your info (I really need to use namcap more ;) )

  • dev tools are needed for the m4 build macros used.
  • until i had sure it didn't conflict with them, i wanted to be safe so i marked it conflicting with everything else.

andreyv commented on 2018-10-23 08:21

I was also developing a PKGBUILD for this software, but didn't upload fast enough. You can use it for reference: https://paste.debian.net/1048593/

Notable differences:

  • Minimized dependencies (namcap warns about this)
  • Fixed libexec dir (also from namcap)
  • Also builds documentation
  • XScreenSaver hacks support (I intended to make it an optional run-time dependency)
  • Is xfce4-dev-tools needed for building?
  • How does this conflict with other screensavers?

Even after enabling XScreenSaver support, I didn't manage to get xfce4-screensaver to find the hacks, though. That would be something to investigate in the future.

Good job with the .pam file — during testing the screensaver didn't unlock properly for me, and perhaps this was the reason.