Package Details: xfce4-multiload-ng-plugin-gtk3 1.5.2-6

Git Clone URL: https://aur.archlinux.org/xfce4-multiload-ng-plugin-gtk3.git (read-only, click to copy)
Package Base: xfce4-multiload-ng-plugin-gtk3
Description: DEPRECATED: Please switch to xfce4-multiload-ng-plugin
Upstream URL: https://udda.github.io/multiload-ng/
Licenses: GPL2
Conflicts: xfce4-multiload-ng-plugin-gtk2, xfce4-multiload-ng-plugin-gtk2-git, xfce4-multiload-ng-plugin-gtk3-git
Submitter: udda
Maintainer: udda (PhotonX)
Last Packager: PhotonX
Votes: 8
Popularity: 0.000000
First Submitted: 2016-11-12 02:13
Last Updated: 2020-12-26 14:21

Pinned Comments

PhotonX commented on 2020-12-26 14:30

The -gtk2 variant of xfce4-multiload-ng-plugin fails to build with Xfce 4.16 so I think, it is time to remove it and have just one xfce4-multiload-ng-plugin package. Thus this package will be superseded with the (identical up to the naming) package xfce4-multiload-ng-plugin: https://aur.archlinux.org/packages/xfce4-multiload-ng-plugin/ Please switch as this package will be deleted soon.

Latest Comments

1 2 Next › Last »

dmitmel commented on 2021-01-03 16:12

PhotonX: nice, thanks

PhotonX commented on 2021-01-03 16:10

@dmitmel: The developer now included the fix in the latest commit, thanks again: https://github.com/udda/multiload-ng/commit/743885da84474bfffc5f5505c0d1a7160de6afef

PhotonX commented on 2020-12-26 14:30

The -gtk2 variant of xfce4-multiload-ng-plugin fails to build with Xfce 4.16 so I think, it is time to remove it and have just one xfce4-multiload-ng-plugin package. Thus this package will be superseded with the (identical up to the naming) package xfce4-multiload-ng-plugin: https://aur.archlinux.org/packages/xfce4-multiload-ng-plugin/ Please switch as this package will be deleted soon.

PhotonX commented on 2020-12-26 09:58

I can reproduce it, thanks for the report and the fix! I will report the problem upstream!

dmitmel commented on 2020-12-24 21:23

No idea if this problem is isolated to my installation, but compilation fails with:

  CCLD     libmultiload-ng.la
/usr/bin/ld:.libs/libmultiload-ng.ver:2: syntax error in VERSION script
collect2: error: ld returned 1 exit status
make: *** [Makefile:503: libmultiload-ng.la] Error 1

This can be fixed by applying the following patch:

diff -Naur a/xfce4/plugin.c b/xfce4/plugin.c
--- a/xfce4/plugin.c    2016-12-05 18:13:59.000000000 +0200
+++ b/xfce4/plugin.c    2020-12-24 22:50:53.839435971 +0200
@@ -25,6 +25,7 @@

 #include <libxfce4util/libxfce4util.h>
 #include <libxfce4panel/xfce-panel-plugin.h>
+#include <libxfce4panel/xfce-panel-macros.h>

 #include "common/multiload.h"
 #include "common/ui.h"

The issue is most likely caused by the recent Xfce 4.16 upgrade: the header file xfce-panel-plugin.h now for some reason doesn't #include the macros one, and so the C compiler believes that XFCE_PANEL_PLUGIN_REGISTER (xfce_constructor); is a variable declaration (???) or something, not a macro invocation.

PhotonX commented on 2020-07-30 21:18

udda pushed a commit fixing the build problems, I added a patch in a silent update. Please report any problems with it!

PhotonX commented on 2020-07-23 17:49

@produnis: I linked the upstream bug report in the comment right below yours. ;)

produnis commented on 2020-07-23 15:01

Hi there, I get error

CC libmultiload_ng_la-plugin.lo CCLD libmultiload-ng.la /sbin/ld: ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-colors.o):(.bss+0x0): multiple definition of graph_types'; ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-autoscaler.o):(.bss+0x0): first defined here /sbin/ld: ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-load-graph.o):(.bss+0x0): multiple definition ofgraph_types'; ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-autoscaler.o):(.bss+0x0): first defined here /sbin/ld: ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-multiload.o):(.bss+0x20): multiple definition of graph_types'; ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-autoscaler.o):(.bss+0x0): first defined here /sbin/ld: ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-multiload-config.o):(.bss+0x0): multiple definition ofgraph_types'; ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-autoscaler.o):(.bss+0x0): first defined here /sbin/ld: ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-preferences.o):(.bss+0x0): multiple definition of graph_types'; ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-autoscaler.o):(.bss+0x0): first defined here /sbin/ld: ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-ui.o):(.bss+0x0): multiple definition ofgraph_types'; ../common/.libs/multiload-ng-core.a(multiload_ng_core_la-autoscaler.o):(.bss+0x0): first defined here

error making: %!s(func() string=0x55b9d8aebbb0)

while installing....

PhotonX commented on 2020-06-14 07:22

@sfner: I reported it upstream but don't assume, there will be a fix any time soon, since development is dead: https://github.com/udda/multiload-ng/issues/70

sfner commented on 2020-06-14 04:04

Now it's not building. ld is complaining about multiple definition of 'graph_types'