Package Details: xfce4-alsa-plugin 0.2.1-1

Git Clone URL: https://aur.archlinux.org/xfce4-alsa-plugin.git (read-only, click to copy)
Package Base: xfce4-alsa-plugin
Description: Simple ALSA volume control for xfce4-panel
Upstream URL: https://github.com/equeim/xfce4-alsa-plugin
Licenses: GPL3
Submitter: equeim
Maintainer: equeim
Last Packager: equeim
Votes: 16
Popularity: 0.86
First Submitted: 2016-06-30 22:27
Last Updated: 2020-01-06 15:22

Latest Comments

bigcajun826 commented on 2020-05-26 14:57

I'm sure this isn't the right fix, but I found this:

https://gitlab.xfce.org/xfce/xfce4-panel/-/commit/659d61ee2901ffe1e34f7dbcf5d8213b7a17d142

So I tried removing the overrides and it seems to work. You can find my patch here if you like:

https://github.com/emerkle826/xfce4-alsa-plugin

xryptor commented on 2020-04-25 23:53

@drfunjohn downgrade vala < 0.48.0 fixed it for me (0.46.6)

drfunjohn commented on 2020-03-16 15:33

Failed during installation:

[2/9] Compiling Vala source ../xfce4-a...ugin-0.2.1/src/xfce4-alsa-plugin.vala.
FAILED: alsa@sha/src/alsamanager.c alsa@sha/src/settings.c alsa@sha/src/settingsdialog.c alsa@sha/src/volumebutton.c alsa@sha/src/volumepopup.c alsa@sha/src/xfce4-alsa-plugin.c alsa.h alsa.vapi 
valac -C --vapidir /home/drfunjohn/Downloads/aur/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.2.1/src/vapi --define=GTK3 --define=XFCE4_13 --pkg gtk+-3.0 --pkg libxfce4panel-2.0 /home/drfunjohn/Downloads/aur/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.2.1/src/vapi/config.vapi /home/drfunjohn/Downloads/aur/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.2.1/src/vapi/gdkkeysyms-2.0.vapi --pkg alsa --color=always --directory alsa@sha --basedir ../xfce4-alsa-plugin-0.2.1/ --library alsa --header alsa.h --vapi ../alsa.vapi ../xfce4-alsa-plugin-0.2.1/src/alsamanager.vala ../xfce4-alsa-plugin-0.2.1/src/settings.vala ../xfce4-alsa-plugin-0.2.1/src/settingsdialog.vala ../xfce4-alsa-plugin-0.2.1/src/volumebutton.vala ../xfce4-alsa-plugin-0.2.1/src/volumepopup.vala ../xfce4-alsa-plugin-0.2.1/src/xfce4-alsa-plugin.vala
libxfce4panel-2.0.vapi:124.3-124.41: error: overriding method `Xfce.PanelPlugin.remote_event' is incompatible with base method `bool Xfce.PanelPluginProvider.remote_event (string, GLib.Value, uint)': too few parameters.
        public virtual signal bool remote_event (string name, GLib.Value value);
        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation failed: 1 error(s), 0 warning(s)
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...

equeim commented on 2018-09-23 23:55

Fixed.

DarkSun commented on 2018-09-23 17:35

It cant get built using python 3.7

Raises Stop Iteration

I installed python3.5 and changed the shebangs in Python scripts in this repo to python3.5

I tried makepkg -si again and it worked!

vita_cell commented on 2018-02-19 15:55

ctx=run_command(cmd_name)

File "/run/media/vita/Almacenamiento3/BUILD/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.1.1/.waf-1.8.21-f82045c32bfe2733639c9d1b6e51d409/waflib/Scripting.py", line 166, in run_command ctx.execute() File "/run/media/vita/Almacenamiento3/BUILD/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.1.1/.waf-1.8.21-f82045c32bfe2733639c9d1b6e51d409/waflib/Scripting.py", line 387, in execute return execute_method(self) File "/run/media/vita/Almacenamiento3/BUILD/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.1.1/.waf-1.8.21-f82045c32bfe2733639c9d1b6e51d409/waflib/Build.py", line 107, in execute self.execute_build() File "/run/media/vita/Almacenamiento3/BUILD/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.1.1/.waf-1.8.21-f82045c32bfe2733639c9d1b6e51d409/waflib/Build.py", line 110, in execute_build self.recurse([self.run_dir]) File "/run/media/vita/Almacenamiento3/BUILD/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.1.1/.waf-1.8.21-f82045c32bfe2733639c9d1b6e51d409/waflib/Context.py", line 134, in recurse user_function(self) File "/run/media/vita/Almacenamiento3/BUILD/xfce4-alsa-plugin/src/xfce4-alsa-plugin-0.1.1/wscript", line 44, in build install_path="{}/xfce4/panel/plugins".format(context.env.LIBDIR) ValueError: zero length field name in format ==> ERROR: Se produjo un fallo en build(). Cancelando...