Package Details: xf86-video-intel-git 1:2.99.917+892+gc6cb1b19-2

Git Clone URL: https://aur.archlinux.org/xf86-video-intel-git.git (read-only)
Package Base: xf86-video-intel-git
Description: X.org Intel i810/i830/i915/945G/G965+ video drivers
Upstream URL: https://01.org/linuxgraphics
Keywords: git intel xf86 xorg xserver
Licenses: custom
Groups: xorg-drivers
Conflicts: xf86-video-i810, xf86-video-intel, xf86-video-intel-legacy, xf86-video-intel-sna, xf86-video-intel-uxa, xorg-server<1.20
Provides: xf86-video-intel, xf86-video-intel-sna, xf86-video-intel-uxa
Replaces: xf86-video-intel-sna, xf86-video-intel-uxa
Submitter: None
Maintainer: yurikoles (Lone_Wolf)
Last Packager: yurikoles
Votes: 120
Popularity: 0.816788
First Submitted: 2008-07-27 16:36
Last Updated: 2019-09-28 13:50

Required by (6)

Sources (1)

Pinned Comments

yurikoles commented on 2018-05-19 00:12

PRs are welcome: https://github.com/yurikoles/xf86-video-intel-git

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11

tjwoosta commented on 2010-08-01 03:20

@td123 its not the packagers fault. If you use makepkg and pacman there are no issues.

You must have been using yaourt because yaourt for some reason misinterprets the inequality symbols in conflicts. Ive noticed this a few times. Its not like it automatically removes the conflicts or anything though, it asks you if you would like to use pacman -Rd to remove the conflics, if you choose no it will ignore it and install the package as normal.

td123 commented on 2010-07-02 18:18

please remove xorg-server<1.6.2 from conflicts because it removed my xorg-server... and I'm running the latest xorg-server

Anonymous comment on 2010-06-01 11:12

dri2proto is also a dependency

td123 commented on 2010-04-30 01:41

I think the pkgbuild should be modified to provides=('xf86-video-intel=2.11.0')

fs4000 commented on 2010-04-18 17:11

Everyone wo wants to build packages should have these installed because they are in the base-devel group.

Anonymous comment on 2010-04-18 13:37

I would add to makedepends automake and autoconf.

ilpianista commented on 2010-04-09 17:16

Hi, please update depends, makedepends, conflicts and provides arrays

depends=('intel-dri>=7.8' 'libpciaccess>=0.10.9' 'libdrm>=2.4.20' 'libxvmc>=1.0.5' 'libxcb>=1.5' 'xcb-util>=0.3.6')
makedepends=('pkgconfig' 'xorg-server>=1.8.0' 'xf86driproto>=2.1.0' 'glproto>=1.4.11' 'mesa>=7.8' 'xineramaproto>=1.2' 'inputproto' 'xorg-util-macros')
conflicts=('xorg-server<1.8.0' 'xf86-video-i810' 'xf86-video-intel-legacy' 'xf86-video-intel')
provides=('xf86-video-intel=2.11')

ilpianista commented on 2010-04-09 16:44

Hi, please update depends, makedepends, conflicts and provides arrays

depends=('intel-dri>=7.8' 'libpciaccess>=0.10.9' 'libdrm>=2.4.20' 'libxvmc>=1.0.5' 'libxcb>=1.5' 'xcb-util>=0.3.6')
makedepends=('pkgconfig' 'xorg-server>=1.8.0' 'xf86driproto>=2.1.0' 'glproto>=1.4.11' 'mesa>=7.8' 'xineramaproto>=1.2' 'inputproto' 'xorg-util-macros')
conflicts=('xorg-server<1.8.0' 'xf86-video-i810' 'xf86-video-intel-legacy')
provides=('xf86-video-intel=2.11')

ilpianista commented on 2010-04-09 16:44

Hi, please update depends, makedepends, conflicts and provides arrays

depends=('intel-dri>=7.8' 'libpciaccess>=0.10.9' 'libdrm>=2.4.20' 'libxvmc>=1.0.5' 'libxcb>=1.5' 'xcb-util>=0.3.6')
makedepends=('pkgconfig' 'xorg-server>=1.8.0' 'xf86driproto>=2.1.0' 'glproto>=1.4.11' 'mesa>=7.8' 'xineramaproto>=1.2' 'inputproto' 'xorg-util-macros')
conflicts=('xorg-server<1.8.0' 'xf86-video-i810' 'xf86-video-intel-legacy')
provides=('xf86-video-intel=2.11')

ilpianista commented on 2010-04-09 16:41

Hi, please update depends, makedepends, conflicts and provides arrays

depends=('intel-dri>=7.8' 'libpciaccess>=0.10.9' 'libdrm>=2.4.20' 'libxvmc>=1.0.5' 'libxcb>=1.5' 'xcb-util>=0.3.6')
makedepends=('pkgconfig' 'xorg-server>=1.8.0' 'xf86driproto>=2.1.0' 'glproto>=1.4.11' 'mesa>=7.8' 'xineramaproto>=1.2' 'inputproto')
conflicts=('xorg-server<1.8.0' 'xf86-video-i810' 'xf86-video-intel-legacy')
provides=('xf86-video-intel=2.11')