Package Details: xf86-video-intel-git 1:2.99.917+892+gc6cb1b19-2

Git Clone URL: https://aur.archlinux.org/xf86-video-intel-git.git (read-only)
Package Base: xf86-video-intel-git
Description: X.org Intel i810/i830/i915/945G/G965+ video drivers
Upstream URL: https://01.org/linuxgraphics
Keywords: git intel xf86 xorg xserver
Licenses: custom
Groups: xorg-drivers
Conflicts: xf86-video-i810, xf86-video-intel, xf86-video-intel-legacy, xf86-video-intel-sna, xf86-video-intel-uxa, xorg-server<1.20
Provides: xf86-video-intel, xf86-video-intel-sna, xf86-video-intel-uxa
Replaces: xf86-video-intel-sna, xf86-video-intel-uxa
Submitter: None
Maintainer: yurikoles (Lone_Wolf)
Last Packager: yurikoles
Votes: 120
Popularity: 0.859101
First Submitted: 2008-07-27 16:36
Last Updated: 2019-09-28 13:50

Required by (6)

Sources (1)

Pinned Comments

yurikoles commented on 2018-05-19 00:12

PRs are welcome: https://github.com/yurikoles/xf86-video-intel-git

Latest Comments

1 2 3 4 5 6 ... Next › Last »

yurikoles commented on 2019-09-28 18:15

@rien333, I can confirm its fixed in 581ddc5d2f55efa2cf5ec76a802fb781ee142b01

yurikoles commented on 2019-09-28 13:41

@rien333,

Thanks for reporting in. It seems like original ticket on FDO is still open, I had wrote a comment asking for rebase/merge. For now I just removed it.

rien333 commented on 2019-09-28 11:50

I suppose the patch is not needed anymore?

patching file src/sna/sna_accel.c
Reversed (or previously applied) patch detected!  Skipping patch.
4 out of 4 hunks ignored -- saving rejects to file src/sna/sna_accel.c.rej

yurikoles commented on 2019-02-28 06:42

@PedroHLC you are right, preparing update.

PedroHLC commented on 2019-02-28 00:32

You should not "replace=(xf86-video-intel", I build packages automatically and add them to a repo, and this line is making everybody be requested to do the replacement.

clpwn commented on 2018-09-10 12:04

FYI, getting a new error on upgrading now that the git remote seems to have changed (I'm using yay).

==> Making package: xf86-video-intel-git 1:2.99.917+847+g25c9a2fc-1 (Mon 10 Sep 2018 12:00:25 PM GMT)
==> Retrieving sources...
==> ERROR: /home/ichi/.cache/yay/xf86-video-intel-git/xf86-video-intel-git is not a clone of https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel.git
    Aborting...
Error downloading sources: xf86-video-intel-git

Solved easily by removing ~/.cache/yay/xf86-video-intel-git/, but worth noting regardless since it breaks the upgrade process.

Morganamilo commented on 2018-05-19 00:15

You should probably pin a comment talking about that repo, I had no idea it was there.

Anyway, I don't know that much about the xorg and driver stack. My comment was looking for conformation. I'm not making a pr unless I know I'm right.

yurikoles commented on 2018-05-19 00:12

PRs are welcome: https://github.com/yurikoles/xf86-video-intel-git

Morganamilo commented on 2018-05-18 05:09

On the same topic as @Fandekasp's comment

Do think think it would be a good idea to just drop the dep? It looks like you're depending on an ABI which would apply to compiled packages. But this package is built from source so wouldn't the ABI not matter?

Fandekasp commented on 2018-05-18 01:37

Package cannot be installed anymore, xorg-server now provides X-ABI-VIDEODRV_VERSION=24.0 but xf86-video-intel-git requires X-ABI-VIDEODRV_VERSION=23