Package Details: xeroxprtdrv 5.20.647.4414-1

Git Clone URL: https://aur.archlinux.org/xeroxprtdrv.git (read-only)
Package Base: xeroxprtdrv
Description: Xerox Unix Print Drivers
Upstream URL: http://www.xerox.com
Keywords: driver printer proprietary
Licenses: custom
Submitter: troyengel
Maintainer: ewirch
Last Packager: ewirch
Votes: 6
Popularity: 0.000131
First Submitted: 2015-03-18 01:50
Last Updated: 2019-01-09 09:11

Latest Comments

1 2 Next › Last »

solloron1 commented on 2018-05-22 20:10

When anyone else launches this do they just get the fax phonebook dialog? There isn't any way to access the actual print manager. Any help on how to get this fixed would be great.

ewirch commented on 2017-09-19 06:30

Allright. Merge problem. Sorry for that. Hashes are updated now.

troyengel commented on 2017-09-15 14:39

it's now orphaned, feel free to maintain

ewirch commented on 2017-09-15 14:36

I applied some improvements to the package and fixed a incompatibility: https://github.com/ewirch/xeroxprtdrv/commits/master

Feel free to use it.

ewirch commented on 2017-09-15 06:45

> echo "As root run the following to detect the printing subsystem:"
> echo "# cd /opt/Xerox/prtsys; /opt/Xerox/prtsys/xeroxquemgr -setprtsubsys"

Why don't you actually execute the command in the post install script?

troyengel commented on 2017-04-24 23:29

The download location changed again with this new release 5.20.602.3898, it's back to what it was before the last release. *shrug*

christoph commented on 2017-01-22 15:55

@troyengel you are awesome, thank you for that blazing fast reaction !

Guys like you are the reason I like this project :)

I will test the Driver Tuesday and give feedback

best regards

Christoph

troyengel commented on 2017-01-22 14:27

I dug though every driver download currently listed for sale on this page (http://www.office.xerox.com/digital-printing-equipment/multifunction-printer/enus.html) and found the WorkCentre 6516 had an even newer package download, but the directory changed from 'CQ8580' to 'WC6515' and is dated Nov 2, 2016.

I've updated the PKGBUILD for this newer version and download location, the only difference shown is the addition of libWorkCentre6515.so; here's our new list:

$ bsdtar -Jvtf xeroxprtdrv-5.20.600.3803-1-x86_64.pkg.tar.xz | grep v5lib/lib | awk '{print $9}' | sort
opt/Xerox/prtsys/v5lib/libASCII2NUp.so
opt/Xerox/prtsys/v5lib/libASCII2PSPlugin.so
opt/Xerox/prtsys/v5lib/libBookletPlugin.so
opt/Xerox/prtsys/v5lib/libBookletRendering.so
opt/Xerox/prtsys/v5lib/libColorQube8580.so
opt/Xerox/prtsys/v5lib/libColorQube8700.so
opt/Xerox/prtsys/v5lib/libColorQube9301.so
opt/Xerox/prtsys/v5lib/libCommonAPI.so
opt/Xerox/prtsys/v5lib/libConcurrency.so
opt/Xerox/prtsys/v5lib/libConstraintEngine.so
opt/Xerox/prtsys/v5lib/libDatabase.so
opt/Xerox/prtsys/v5lib/libDriverFeature.so
opt/Xerox/prtsys/v5lib/libGeneric.so
opt/Xerox/prtsys/v5lib/libGuiTools.so
opt/Xerox/prtsys/v5lib/libImageRendering.so
opt/Xerox/prtsys/v5lib/libNUpPlugin.so
opt/Xerox/prtsys/v5lib/libNUpRendering.so
opt/Xerox/prtsys/v5lib/libNetworking.so
opt/Xerox/prtsys/v5lib/libOSInterface.so
opt/Xerox/prtsys/v5lib/libOfficeStandard.so
opt/Xerox/prtsys/v5lib/libPDF2PSPlugin.so
opt/Xerox/prtsys/v5lib/libPDF2PSRendering.so
opt/Xerox/prtsys/v5lib/libPDLOutput.so
opt/Xerox/prtsys/v5lib/libPDLWriter.so
opt/Xerox/prtsys/v5lib/libPhaser4622.so
opt/Xerox/prtsys/v5lib/libPhaser7100.so
opt/Xerox/prtsys/v5lib/libSoftCollationPlugin.so
opt/Xerox/prtsys/v5lib/libWorkCentre3335.so
opt/Xerox/prtsys/v5lib/libWorkCentre3615.so
opt/Xerox/prtsys/v5lib/libWorkCentre3655.so
opt/Xerox/prtsys/v5lib/libWorkCentre4265.so
opt/Xerox/prtsys/v5lib/libWorkCentre5325.so
opt/Xerox/prtsys/v5lib/libWorkCentre5845.so
opt/Xerox/prtsys/v5lib/libWorkCentre5945.so
opt/Xerox/prtsys/v5lib/libWorkCentre6515.so
opt/Xerox/prtsys/v5lib/libWorkCentre6605.so
opt/Xerox/prtsys/v5lib/libWorkCentre6655.so
opt/Xerox/prtsys/v5lib/libWorkCentre7220.so
opt/Xerox/prtsys/v5lib/libWorkCentre7830.so
opt/Xerox/prtsys/v5lib/libWorkCentre7970.so
opt/Xerox/prtsys/v5lib/libXMLParser.so
opt/Xerox/prtsys/v5lib/libXeroxColor570.so
opt/Xerox/prtsys/v5lib/libXeroxColorC60.so
opt/Xerox/prtsys/v5lib/libXeroxD136.so
opt/Xerox/prtsys/v5lib/libXeroxD95.so
opt/Xerox/prtsys/v5lib/libgcc_s.so.1
opt/Xerox/prtsys/v5lib/libstdc++.so.6

troyengel commented on 2017-01-22 13:40

@christoph - done, it was simple, the drivers are in an updated version of the package hiding on their servers. I just committed the files to upgrade us from 5.20.597.3452 to 5.20.598.3490. If anyone knows of a newer package hiding just say so, you can't browse it manually: http://download.support.xerox.com/pub/drivers/CQ8580/drivers/linux/ar/

$ bsdtar -Jvtf xeroxprtdrv-5.20.598.3490-1-x86_64.pkg.tar.xz | grep v5lib/lib | awk '{print $9}' | sort
opt/Xerox/prtsys/v5lib/libASCII2NUp.so
opt/Xerox/prtsys/v5lib/libASCII2PSPlugin.so
opt/Xerox/prtsys/v5lib/libBookletPlugin.so
opt/Xerox/prtsys/v5lib/libBookletRendering.so
opt/Xerox/prtsys/v5lib/libColorQube8580.so
opt/Xerox/prtsys/v5lib/libColorQube8700.so
opt/Xerox/prtsys/v5lib/libColorQube9301.so
opt/Xerox/prtsys/v5lib/libCommonAPI.so
opt/Xerox/prtsys/v5lib/libConcurrency.so
opt/Xerox/prtsys/v5lib/libConstraintEngine.so
opt/Xerox/prtsys/v5lib/libDatabase.so
opt/Xerox/prtsys/v5lib/libDriverFeature.so
opt/Xerox/prtsys/v5lib/libGeneric.so
opt/Xerox/prtsys/v5lib/libGuiTools.so
opt/Xerox/prtsys/v5lib/libImageRendering.so
opt/Xerox/prtsys/v5lib/libNUpPlugin.so
opt/Xerox/prtsys/v5lib/libNUpRendering.so
opt/Xerox/prtsys/v5lib/libNetworking.so
opt/Xerox/prtsys/v5lib/libOSInterface.so
opt/Xerox/prtsys/v5lib/libOfficeStandard.so
opt/Xerox/prtsys/v5lib/libPDF2PSPlugin.so
opt/Xerox/prtsys/v5lib/libPDF2PSRendering.so
opt/Xerox/prtsys/v5lib/libPDLOutput.so
opt/Xerox/prtsys/v5lib/libPDLWriter.so
opt/Xerox/prtsys/v5lib/libPhaser4622.so
opt/Xerox/prtsys/v5lib/libPhaser7100.so
opt/Xerox/prtsys/v5lib/libSoftCollationPlugin.so
opt/Xerox/prtsys/v5lib/libWorkCentre3335.so
opt/Xerox/prtsys/v5lib/libWorkCentre3615.so
opt/Xerox/prtsys/v5lib/libWorkCentre3655.so
opt/Xerox/prtsys/v5lib/libWorkCentre4265.so
opt/Xerox/prtsys/v5lib/libWorkCentre5325.so
opt/Xerox/prtsys/v5lib/libWorkCentre5845.so
opt/Xerox/prtsys/v5lib/libWorkCentre5945.so
opt/Xerox/prtsys/v5lib/libWorkCentre6605.so
opt/Xerox/prtsys/v5lib/libWorkCentre6655.so
opt/Xerox/prtsys/v5lib/libWorkCentre7220.so
opt/Xerox/prtsys/v5lib/libWorkCentre7830.so
opt/Xerox/prtsys/v5lib/libWorkCentre7970.so
opt/Xerox/prtsys/v5lib/libXMLParser.so
opt/Xerox/prtsys/v5lib/libXeroxColor570.so
opt/Xerox/prtsys/v5lib/libXeroxColorC60.so
opt/Xerox/prtsys/v5lib/libXeroxD136.so
opt/Xerox/prtsys/v5lib/libXeroxD95.so
opt/Xerox/prtsys/v5lib/libgcc_s.so.1
opt/Xerox/prtsys/v5lib/libstdc++.so.6

christoph commented on 2017-01-22 10:20

Hi, can you please add new Drivers who also support the new Workcentre series ?

http://www.support.xerox.com/support/workcentre-3335-3345/downloads/enus.html?operatingSystem=linux&fileLanguage=en

Best regards,

Christoph