Package Details: xboxdrv-develop-git 0.8.4.r410.g1aebab2-1

Git Clone URL: https://aur.archlinux.org/xboxdrv-develop-git.git (read-only, click to copy)
Package Base: xboxdrv-develop-git
Description: An XBox/XBox 360 gamepad driver - as alternative to the xpad-kernel module - with more configurability, runs in userspace and supports a multitude of controllers. Bleeding edge version.
Upstream URL: https://xboxdrv.gitlab.io
Licenses: GPL3
Conflicts: xboxdrv
Provides: xboxdrv
Submitter: Stunts
Maintainer: Stunts
Last Packager: Stunts
Votes: 1
Popularity: 0.000000
First Submitted: 2017-08-09 21:16
Last Updated: 2018-08-20 23:56

Dependencies (10)

Required by (4)

Sources (3)

Latest Comments

hadogenes commented on 2021-04-12 08:43

I think the pkgver() should be
printf "%s.r%s.%s" "$(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/^v//')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
and deps should be corrected to
depends=('libx11' 'dbus-glib' 'libusb' 'dbus-python' 'systemd' 'fmt' 'bluez-libs') makedepends=('git' 'scons' 'boost' 'pkgconfig' 'cmake')
and add
prepare() { cd ${srcdir}/${_pkgname} git submodule update --recursive --init }