Package Details: x264-git 157.r2969.gd4099dd4-1

Git Clone URL: https://aur.archlinux.org/x264-git.git (read-only)
Package Base: x264-git
Description: Open Source H264/AVC video encoder (git version)
Upstream URL: https://www.videolan.org/developers/x264.html
Keywords: avc h.264 h264 libx264 mpeg mpeg-4 mpeg4
Licenses: GPL
Conflicts: libx264, libx264-10bit, libx264-all, x264
Provides: libx264, libx264-git, libx264.so, x264
Replaces: libx264-10bit-git, libx264-all-git, libx264-git
Submitter: pressh
Maintainer: dbermond
Last Packager: dbermond
Votes: 242
Popularity: 0.191520
First Submitted: 2008-03-18 09:05
Last Updated: 2019-06-02 14:20

Dependencies (9)

Required by (91)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

michalrus commented on 2014-11-16 01:01

@PelPix, works now, must've been fixed between 27th and 30th of September. =) Thank you!

PelPix commented on 2014-09-30 06:26

@michalrus

Can't reproduce this either. I do get the warning, but if I force compilation anyway with the flag, it's totally fine. Can you post exactly what you're doing?

michalrus commented on 2014-09-27 13:15

@PelPix

Dunno why. :(

However, after recent update of official `gpac`, I'm getting:

$ ./configure
Warning: gpac is too old, update to 2007-06-21 UTC or later
...

And previously compiled `x264-git` says:

x264: error while loading shared libraries: libavformat.so.55: cannot open shared object file: No such file or directory

(The second is kind of obvious, but maybe you should bump the version here, so that people recompile after the gpac update.)

Still, the GPAC test in ./configure fails. After hardcoding gpac='yes', I'm getting:

/usr/bin/ld: /usr/lib/gcc/x86_64-unknown-linux-gnu/4.9.1/../../../../lib/libgpac_static.a(downloader.o): undefined reference to symbol 'SSL_free'
/usr/lib/libssl.so.1.0.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:185: recipe for target 'x264' failed
make: *** [x264] Error 1
==> ERROR: A failure occurred in build().

… so something is probably really wrong. :(

PelPix commented on 2014-09-23 00:07

Can't reproduce.

PelPix commented on 2014-09-20 18:45

@michalrus

Thanks for the report! I'll get right on it.

michalrus commented on 2014-09-20 13:03

Namcap says:

x264-git E: Dependency ffms2 detected and not included (libraries ['usr/lib/libffms2.so.3'] needed in files ['usr/bin/x264'])

Lynthium commented on 2014-06-12 10:37

@PelPix

Yes, thank you =)

PelPix commented on 2014-06-11 23:43

@Lynden

Done. Better now?

Lynthium commented on 2014-06-11 17:43

Please add libx264 to the provides&conflicts list. The package "libx264" in extra conflicts with this one.

PelPix commented on 2014-01-28 05:13

@Kingedgar It's not out of date. It was incorrectly marked.