Package Details: wxsvg 1.5.19-1

Git Clone URL: https://aur.archlinux.org/wxsvg.git (read-only)
Package Base: wxsvg
Description: C++ library to create, manipulate and render SVG files
Upstream URL: http://wxsvg.sourceforge.net/
Licenses: custom:wxWindows
Submitter: xyproto
Maintainer: artafinde
Last Packager: artafinde
Votes: 59
Popularity: 0.344757
First Submitted: 2011-12-14 17:07
Last Updated: 2019-06-25 07:47

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

MaNNa commented on 2013-08-29 05:15


Also depends on webkitgtk2 to build.

______________________________________________________________________________________________________________________
In God's love,
†MaNNa <{{{>< ...to You all thanks and glory Lord Yeshua!

And Jesus prayed to The Father, "And this is the way to eternal life - to know You, the Only True God, and Jesus Christ the One You sent to earth.

MaNNa commented on 2013-08-28 16:17


Build gets down to this point and fails:

/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.1/../../../../lib/libwx_gtk2u_webview-2.9.so: undefined reference to `webkit_web_back_forward_list_get_limit'
collect2: error: ld returned 1 exit status
make[1]: *** [svgview] Error 1
make[1]: Leaving directory `/tmp/packerbuild-0/wxsvg/wxsvg/src/wxsvg-1.1.16/svgview'
make: *** [all-recursive] Error 1
==> ERROR: A failure occurred in build().
Aborting...
The build failed.

Must be something with wxsvg I suspect.

______________________________________________________________________________________________________________________
In God's love,
†MaNNa <{{{>< ...to You all thanks and glory Lord Yeshua!

And Jesus prayed to The Father, "And this is the way to eternal life - to know You, the Only True God, and Jesus Christ the One You sent to earth.

migrev commented on 2013-08-21 14:44

DVDStyler (2.5.2) now requires wxsvg with libav support. Would you care adding it so I can update that pkg? Thanks, mate.

jomasti commented on 2013-04-23 17:36

The previous version of the source didn't have the appropriate flags for execution.

ozz commented on 2013-04-22 00:07

Looks like the source archive was updated in-place a few minutes ago. It's the same version but the md5sum now doesn't match. Seems somewhat suspicious, might want to verify that there really was an update (why wasn't the version increased?).

awagner commented on 2013-02-21 08:42

pkgname=wxsvg
pkgver=1.1.13
pkgrel=1
pkgdesc="C++ library to create, manipulate and render SVG files"
arch=('i686' 'x86_64')
url="http://wxsvg.sourceforge.net/"
license=('custom:wxWindows')
depends=('wxgtk2.9' 'cairo' 'ffmpeg')
options=('!libtool')
source=("http://downloads.sourceforge.net/project/wxsvg/wxsvg/${pkgver}/wxsvg-${pkgver}.tar.bz2")
md5sums=('e8ab2cd0398fbc5cafff2cee43150ec5')

build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --with-wx-config=/usr/bin/wx-config-2.9
make
}

package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/wxsvg/COPYING"
}

Anonymous comment on 2013-01-22 19:13

Hint (It took me some time to figure out): You must use cairo backend. DVDStyler may crash if using libart (at least for my menu) because of missing alpha channel support.

migrev commented on 2013-01-21 11:25

Also, dvdstyler 2.4 requires wxgtk 2.9, hence this package should also be built with --with-wx-config=/usr/bin/wx-config-2.9

Thx

migrev commented on 2013-01-21 11:16

Rendering with cairo is fixed 1.1.12, so --enable-render=libart is not needed anymore.

migrev commented on 2013-01-21 10:58

1.1.12 is out. C'mon man.