Package Details: wxformbuilder-git 3.9.0.r48f2f0f-1

Git Clone URL: https://aur.archlinux.org/wxformbuilder-git.git (read-only)
Package Base: wxformbuilder-git
Description: Designer, GUI builder, and RAD tool For wxWidgets
Upstream URL: https://sourceforge.net/projects/wxformbuilder/
Keywords: C++ Designer GUI Lua PHP Python RAD wxGtk wxWidgets XRC
Licenses: GPL
Conflicts: wxformbuilder, wxformbuilder-svn
Provides: wxformbuilder
Submitter: jgmdev
Maintainer: jgmdev
Last Packager: jgmdev
Votes: 21
Popularity: 0.000140
First Submitted: 2016-10-03 16:35
Last Updated: 2019-02-18 16:08

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

jgmdev commented on 2017-09-16 00:56

So I tought last change fixed the issue because it compiled fine, but then a user emails me with some premake error. So I tried building on a clean directory and got another set of errors, after scratching my head for a while I discovered the real culprit:

https://github.com/wxFormBuilder/wxFormBuilder/tree/master/build/premake/linux/obj/Release

It seems someone forgot to clean its object files and did a "git add ." on a hurry...

Now it should finally build normally again!!! Now I have to report this issue mainstream.

jgmdev commented on 2017-09-15 20:07

@froh Fixed, thanks for sharing, funny that I missed the S from CXXFLAGS (facepalm).

froh commented on 2017-09-09 10:27

Still fails on X86_64.
The -fPIC must go into CXXFLAGS, not CXXFLAG.
In addition, wxwidgets include paths are missing (at least for me).
What did work:
i) remove the CXXFLAG=... part from the make invocation
ii) prepend lines
export CFLAGS=-fPIC\ $(wx-config --cflags)
export CXXFLAGS=-fPIC\ $(wx-config --cxxflags)
of course, transferring to exports is just a matter of readability, adding the wx-config stuff is what matters.

jgmdev commented on 2017-08-18 17:49

I added the -fPIC flag, thanks all for testing.

ase1590 commented on 2017-08-18 12:26

The build outright fails on Arch X86_64, complaining that fPIC needs to be set in order to compile.

adding mrbit's 'make config' option fixes the build.

Pezo commented on 2017-08-08 07:29

x86_64

jgmdev commented on 2017-08-07 19:55

@Pezo and @mrbit

Which platform? 64 or 32?

Pezo commented on 2017-08-07 15:34

Build fails for me without -fPIC, works when I add it.

jgmdev commented on 2017-07-28 04:36

@mrbit

Added boost dependency but the CXXFLAG=-fPIC option gave me some issues with premake if I recall correctly.

mrbit commented on 2017-07-22 18:58

please fix pkgbuild
add depends= 'boost'
make config=release CXXFLAG=-fPIC