Package Details: wrk 4.1.0-4

Git Clone URL: https://aur.archlinux.org/wrk.git (read-only, click to copy)
Package Base: wrk
Description: Modern HTTP benchmarking tool
Upstream URL: https://github.com/wg/wrk/
Licenses: Apache
Submitter: pcarrier
Maintainer: drakkan
Last Packager: drakkan
Votes: 47
Popularity: 0.23
First Submitted: 2013-01-22 23:09
Last Updated: 2019-07-11 06:08

Latest Comments

1 2 Next › Last »

0xdev commented on 2020-05-07 06:35

@drakkan Yeah, sorry, that was my issue. I reinstalled Arch and it seems that all work fine. Thanks.

drakkan commented on 2020-05-04 07:16

@0xdev, it builds fine for me, can you please try to build using a clean chroot? Thanks

0xdev commented on 2020-05-03 17:39

Doesn't compile: LUAJIT src/wrk.lua LINK wrk ld: error: obj/bytecode.o: SHT_STRTAB string table section [index 3] is non-null terminated collect2: error: ld returned 1 exit status make: *** [Makefile:45: wrk] Error 1

allspark commented on 2019-07-11 05:20

Hi,

the arch is not any. its's

arch=('x86_64' 'aarch64')

jkhsjdhjs commented on 2018-07-28 19:35

This also works on aarch64. Would be nice if you could add it to the architectures in the PKGBUILD. Thanks! :)

EDIT: Thanks for the immediate fix!

drakkan commented on 2018-01-05 11:18

actually luajit 2.1 it is still beta. I'll try to patch wrk to build against luajit 2.1 when it will be available in arch community repo if the issue is not yet fixed by wrk upstream, thanks

daurnimator commented on 2018-01-05 10:32

Doesn't compile with luajit-2.1 installed. Filed https://github.com/wg/wrk/issues/314

SilverRainZ commented on 2017-11-13 07:02

Hello, current wrk's lua script can not found the lua package install by pacman. Build wrk with `make WITH_OPENSSL=/usr WITH_LUAJIT=/usr` can solve this.

Besides, luajit should be a dependency of wrk.

pcarrier commented on 2014-04-11 08:34

Sounds good, thanks ;)

drakkan commented on 2014-04-11 07:45

updated PKGBUILD, please let me know if you want I maintain this package

# Maintainer: Pierre Carrier <pierre@gcarrier.fr>
pkgname=wrk
pkgver=3.1.0
pkgrel=1
pkgdesc="Modern HTTP benchmarking tool"
arch=(i686 x86_64)
url=https://github.com/wg/wrk
license=(Apache)
depends=()
makedepends=()
source=(https://github.com/wg/$pkgname/archive/$pkgver.tar.gz)
md5sums=(ad0cbd1a17e4c04d68d92e858fa4c938)
options=('!makeflags'
'!buildflags')

build() {
cd "$srcdir/$pkgname-$pkgver"
make
}

package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm755 wrk "$pkgdir/usr/bin/wrk"
}

# vim:set ts=2 sw=2 et: