Package Details: wp-cli 2.4.0-4

Git Clone URL: https://aur.archlinux.org/wp-cli.git (read-only, click to copy)
Package Base: wp-cli
Description: A command-line tool for managing WordPress
Upstream URL: http://wp-cli.org/
Licenses: MIT
Submitter: 0x6d617474
Maintainer: 0x6d617474
Last Packager: 0x6d617474
Votes: 12
Popularity: 0.021560
First Submitted: 2014-05-16 18:44
Last Updated: 2021-01-30 21:59

Latest Comments

1 2 3 4 Next › Last »

caleb commented on 2021-02-27 13:44

The dependencies on this are out of date because php in Arch Linux repos is now php8 and this app is not yet compatible. It must me run under php7. There are php7 packages in [community], so that should be the dependency and the shebang line will need fixing.

0x6d617474 commented on 2021-01-30 22:00

Fixed git dependency via --prefer-dist in the composer update step.

DrZaius commented on 2021-01-29 01:48

Now requires git as a dependency: "Failed to clone https://github.com/wp-cli/wp-cli.git, git was not found, check that it is installed and in your PATH env."

0x6d617474 commented on 2021-01-14 02:40

I have added a patch to fix the compatibility issues with composer 2.x.

I was hoping that a new release of the upstream package would fix this such that we wouldn't need to address the issue in the package, but it's been long enough and a new release doesn't look like it is coming soon

The build step now includes a call to update specific dependencies to a minimum version that supports composer 2.x.

exoro commented on 2020-12-02 16:58

I get this error: Your lock file does not contain a compatible set of packages. Please run composer update.

Problem 1 - cweagans/composer-patches is locked to version 1.6.7 and an update of this package was not requested. - cweagans/composer-patches 1.6.7 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint. Problem 2 - dealerdirect/phpcodesniffer-composer-installer is locked to version v0.5.0 and an update of this package was not requested. - dealerdirect/phpcodesniffer-composer-installer v0.5.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint. Problem 3 - cweagans/composer-patches 1.6.7 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint. - wp-cli/wp-cli dev-master requires cweagans/composer-patches ^1.6 -> satisfiable by cweagans/composer-patches[1.6.7]. - wp-cli/wp-cli is locked to version dev-master and an update of this package was not requested.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2. Building phar... Missing vendor/autoload.php ==> ERROR: A failure occurred in build(). Aborting... error making: wp-cli

lkrms commented on 2020-05-12 05:37

That's a much better way to solve the mustache issue. Thanks for the patch :)

0x6d617474 commented on 2020-04-28 00:42

This package will stay in sync with the upstream wp-cli-bundle release schedule, since the bundle is the recommended way to install the wp-cli software.

As such, even if a new release of the wp-cli framework is released, this package will not update until the corresponding wp-cli-bundle is released.

I have applied a patch to utilize mustache 2.13.0 in order to avoid compatibility issues with PHP 7.4, which should stabilize things until the next bundle release.

Please report any issues with the inclusion of the 2.13.0 release of mustache here, rather than with the wp-cli authors.

lkrms commented on 2020-04-06 23:35

Thanks for all of your work on this. Given wp-cli's version numbering has been detached from wp-cli-bundle's, I've made some PKGBUILD changes you might want to include or adapt, rather than waiting for the next point release of the bundle: https://github.com/lkrms/aur-wp-cli/commit/58751fb0e663d73d55b4e1ff5c248cd7a47c2888

0x6d617474 commented on 2020-02-29 02:42

Waiting for upstream fixes for the 2.4.1 release.

https://github.com/wp-cli/wp-cli/issues/5359 https://github.com/wp-cli/wp-cli-bundle/issues/183

0x6d617474 commented on 2019-01-06 02:58

The upstream maintainer re-tagged the commit for 2.1.0 to fix the version issue. I've updated the pkgsums to reflect the new tag, and removed the workaround from the pkgbuild file.