Package Details: woeusb 3.3.0-2

Git Clone URL: https://aur.archlinux.org/woeusb.git (read-only, click to copy)
Package Base: woeusb
Description: A Linux program to create Windows USB stick installer from a Windows DVD or an image
Upstream URL: https://github.com/slacka/WoeUSB
Licenses: GPL3
Conflicts: woeusb-git
Submitter: aimileus
Maintainer: IdleGandalf
Last Packager: IdleGandalf
Votes: 59
Popularity: 3.14
First Submitted: 2018-06-14 10:56
Last Updated: 2019-09-06 10:46

Latest Comments

1 2 3 Next › Last »

harryyoud commented on 2020-02-13 23:07

In fact, if you want to keep with the GitHub tarballs, this snippet works well too:

grep 'filter=version' .gitattributes | cut -d' ' -f1 | while read file; do
        sed -i "s/@@WOEUSB_VERSION@@/${pkgver}/" $file
done

harryyoud commented on 2020-02-13 22:52

Version needs bumping to 3.3.1

To set the version in the files (and therefore the man pages and version flags), the PKGBUILD needs to download the sources with git (not a tarball), and run this snippet in prepare:

git config --local include.path $(pwd)/.gitconfig
rm .git/index
git checkout HEAD .

Sources line:

"WoeUSB-${pkgver}::git+https://github.com/slacka/WoeUSB.git#tag=v${pkgver}"

IdleGandalf commented on 2020-01-20 07:13

@Synthead Compiles fine here, besides, maybe you should check existing dependencies before posting.

Synthead commented on 2020-01-19 20:54

Not sure if this is a woeusb issue or a packaging issue:

$ woeusb --help
WoeUSB @@WOEUSB_VERSION@@ Help Information
...

Synthead commented on 2020-01-19 20:53

Please add wxgtk2 as a dependency.

checking for wx-config... no
configure: error: 
                    wxWidgets must be installed on your system.

                    Please check that wx-config is in path, the directory
                    where wxWidgets libraries are installed (returned by
                    'wx-config --libs' or 'wx-config --static --libs' command)
                    is in LD_LIBRARY_PATH or equivalent variable and
                    wxWidgets version is 2.8.4 or above.

==> ERROR: A failure occurred in prepare().
    Aborting...

iGwadaa commented on 2019-11-07 08:43

woeusb 3.3.0-2 : /tmp/yaourt-tmp-user1/aur-woeusb/./PKGBUILD: line 27: autoreconf: command not found

IdleGandalf commented on 2019-09-08 10:39

@zerodef What is it that you are implying?

zer0def commented on 2019-09-08 10:29

Hey bud https://github.com/zer0def/PKGBUILDs/commit/6ffe6d7b13c9ca50e08b88603f07a56c677a0bf5.patch :)

jamespharvey20 commented on 2019-09-02 10:24

There's a patch for the /usr/sbin/woeusb: line 1676: echo: write error: Invalid argument problem linked to at https://github.com/slacka/WoeUSB/issues/267

Although a commit was pushed upstream a month ago with a patch to fix this, and an update to the PKGBUILD to include it, this was never pushed to the AUR. When doing so, pkgrel needs to be updated to 2. The PKGBUILD was modified on github adding the patch but left pkgrel as 1.

RickAngel commented on 2019-07-02 14:31

/usr/bin/woeusb: line 1676: echo: write error: Invalid argument

1676 echo 0 > /proc/sys/vm/dirty_background_bytes 1677 echo 0 > /proc/sys/vm/dirty_bytes

Even as root on the command line I cannot write 0 to dirty_background_bytes, not even using systctl. Maybe 0 is a really an invalid argument for that variable on 4.19.55-2-lts.

sysctl -w vm.dirty_background_bytes=0

sysctl: setting key "vm.dirty_background_bytes": Invalid argument