Package Details: woeusb-git 3.3.0.r0.g5e9a3a7-1

Git Clone URL: https://aur.archlinux.org/woeusb-git.git (read-only)
Package Base: woeusb-git
Description: A Linux program to create Windows USB stick installer from a real Windows DVD or an image
Upstream URL: https://github.com/WoeUSB/WoeUSB-frontend-wxgtk
Licenses: GPL3
Conflicts: woeusb
Provides: woeusb
Submitter: darkfm
Maintainer: DragonX256
Last Packager: DragonX256
Votes: 125
Popularity: 1.48
First Submitted: 2017-06-20 07:52
Last Updated: 2019-04-17 09:00

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

Techman35 commented on 2017-07-20 06:13

wxgtk-common is installed but the file dont exist

[techman@tech-os woeusb-git]$ sudo pacman -S wxgtk-common
warning: wxgtk-common-3.0.3.1-7 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) wxgtk-common-3.0.3.1-7

Total Download Size: 2.34 MiB
Total Installed Size: 11.63 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] n
[techman@tech-os woeusb-git]$ cd /usr/include/wx-3.0/wx/
[techman@tech-os wx]$ ls
aui gtk meta private protocol richtext unix xrc
generic html persist propgrid ribbon stc xml
[techman@tech-os wx]$

darkfm commented on 2017-07-20 02:47

Can you check if file '/usr/include/wx-3.0/wx/wxprec.h' exists in your system? It should've been installed by wxgtk-common as a dependency of wxgtk2.

Techman35 commented on 2017-07-19 21:56

g++ -DHAVE_CONFIG_H -I. -I/usr/lib/wx/include/gtk2-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -D__WXGTK__ -pthread -s -O1 -Wall -Wclobbered -Wempty-body -Wmissing-field-initializers -Wsign-compare -Wtype-limits -Wuninitialized -s -O1 -Wall -Wclobbered -Wempty-body -Wmissing-field-initializers -Wsign-compare -Wtype-limits -Wuninitialized -MT MainPanel.o -MD -MP -MF .deps/MainPanel.Tpo -c -o MainPanel.o MainPanel.cpp
In file included from MainPanel.cpp:20:0:
MainPanel.hpp:20:10: fatal error: wx/wxprec.h: No such file or directory
#include "wx/wxprec.h"
^~~~~~~~~~~~~
compilation terminated.
make[3]: *** [Makefile:598: MainPanel.o] Error 1
make[3]: Leaving directory '/home/techman/woeusb-git/src/WoeUSB/src'
make[2]: *** [Makefile:674: all-recursive] Error 1
make[2]: Leaving directory '/home/techman/woeusb-git/src/WoeUSB/src'
make[1]: *** [Makefile:445: all] Error 2
make[1]: Leaving directory '/home/techman/woeusb-git/src/WoeUSB/src'
make: *** [Makefile:455: all-recursive] Error 1
==> ERROR: A failure occurred in build().

:(

87dv commented on 2017-07-14 05:03

It works, thanks!

sa1t commented on 2017-07-03 00:27

==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: r486.v2.1.1-4-g57a510b
==> ERROR: Makepkg was unable to build winusb-git.

darkfm commented on 2017-07-02 06:31

The fix is upstream now and I've updated accordingly.

klore commented on 2017-07-02 05:59

Hello, finally it works, thank you

darkfm commented on 2017-07-01 22:34

The fix for this is running 'autoreconf --force --install', but since upstream doesn't have a README file, I have to create an empty one in the makepkg, which I've done as a temporary workaround, but I'm gonna submit a patch to upstream. In the meantime, try if the new version works for you.

klore commented on 2017-07-01 18:56

Hello, I had try to install, got this


libtool: Version mismatch error. This is libtool 2.4.2 Debian-2.4.2-1ubuntu1, but the
libtool: definition of this LT_INIT comes from libtool 2.4.6.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2 Debian-2.4.2-1ubuntu1
libtool: and run autoconf again.
make[3]: *** [Makefile:418: woeusbgui] Error 63
make[3]: Leaving directory '/tmp/pamac-build-user/woeusb-git/src/WoeUSB/src'
make[2]: *** [Makefile:537: all-recursive] Error 1
make[2]: Leaving directory '/tmp/pamac-build-user/woeusb-git/src/WoeUSB/src'
make[1]: *** [Makefile:324: all] Error 2
make[1]: Leaving directory '/tmp/pamac-build-user/woeusb-git/src/WoeUSB/src'
make: *** [Makefile:355: all-recursive] Error 1
==> ERROR: A failure occurred in build().
Aborting...

darkfm commented on 2017-06-28 07:06

I couldn't reproduce that bug, however, I uploaded a fix that might work based on your error log.