Package Details: wlc-git 0.0.7.r22.g12ee978-2

Git Clone URL: https://aur.archlinux.org/wlc-git.git (read-only, click to copy)
Package Base: wlc-git
Description: wayland compositor library
Upstream URL: https://github.com/Cloudef/wlc
Keywords: wayland
Licenses: MIT
Conflicts: wlc
Provides: wlc
Submitter: Earnest
Maintainer: Earnest
Last Packager: Earnest
Votes: 40
Popularity: 0.000000
First Submitted: 2015-08-10 13:37
Last Updated: 2017-01-22 19:32

Latest Comments

« First ‹ Previous 1 2

sekret commented on 2016-02-01 21:26

Could you please add 'armv7h' to the arch line? I just compiled on my raspberry pi 2 and it worked fine :)

ksj commented on 2016-01-23 13:17

xcb-util-wm package is mandatory for build this package.
Please change the dependencies.

Earnest commented on 2015-10-30 15:46

It's weird that I missed that, thanks for spotting it. Now fixed.

yannicklm commented on 2015-10-29 18:34

The PKGBUILD is incorrect, it contains:

cmake -DCMAKE-BUILD_TYPE=Upstream

It should be:

cmake -DCMAKE_BUILD_TYPE=Upstream


(note the underscore replacing the dash)

Earnest commented on 2015-09-25 12:21

libxkbcommon is already a dependency and has been for quite some time.

It does appear that xcb-util-image is a compile-time and optional dependency for wlc's xwayland support. Upstream has now documented this as such.

The handling of plugins such as this will change in the future too.

freezway commented on 2015-09-24 03:11

Please add xcb-util-image and libxkbcommon to the dependencies

karol_007 commented on 2015-08-25 22:12

@Floppie
You're expected to have base-devel group installed: https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

Floppie commented on 2015-08-25 20:49

"make" should also be listed as a dependency. Building this fails if make is not installed - not that I'm particularly surprised about that :)

Thanks!

Earnest commented on 2015-08-18 12:34

Good call, done. It was a bit silly of me to miss that.

WorMzy commented on 2015-08-18 11:54

Please could you add libx11 and libgl to the makedepends array, the build currently fails if these are not present:

[without libx11]:
CMake Error at /usr/share/cmake-3.3/Modules/FindX11.cmake:439 (message):
Could not find X11

[without libgl]:
CMake Error at /usr/share/cmake-3.3/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find GLESv2 (missing: GLESv2_LIBRARIES GLESv2_INCLUDE_DIRS)

Cheers.

P.S. You should also add your details to a maintainer tag at the top of the PKGBUILD, e.g.

# Maintainer: Earnest Earnestly <earnest [at] mymail [dot] com