Package Details: wkhtmltopdf-static 0.12.6-2

Git Clone URL: https://aur.archlinux.org/wkhtmltopdf-static.git (read-only, click to copy)
Package Base: wkhtmltopdf-static
Description: Shell utility to convert HTML to PDF using Webkit and Qt (upstream static build)
Upstream URL: https://wkhtmltopdf.org/
Licenses: GPL3
Conflicts: wkhtmltopdf
Provides: wkhtmltopdf=0.12.6
Submitter: foutrelis
Maintainer: phillid
Last Packager: phillid
Votes: 52
Popularity: 0.000143
First Submitted: 2010-02-06 14:46
Last Updated: 2020-06-30 09:36

Required by (15)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

dreivier commented on 2015-08-31 15:50

apparently icu48 became icu-48 on AUR.

phillid commented on 2015-08-05 22:25

Unsure why this was flagged out-of-date; maybe you're getting confused with testing releases provided upstream? Unflagging.

psytoolkit commented on 2015-02-11 17:12

icu48 fixed it for me, great!

phillid commented on 2015-02-10 23:48

All done. I've added it as an `optdepends` for both arches. I've only ever seen the problem on x86_64, but it won't hurt to blanket it.

kageurufu commented on 2015-02-10 18:51

No problem at all, and it looks like icu48 has updated their package with my changes!

Thanks

phillid commented on 2015-02-10 12:04

kageurufu, thank you for your work. I'll add icu48 as an optdepends soon, or once it's fixed.

Cheers

kageurufu commented on 2015-02-09 23:51

The problem is that the QT the debian builds are linked with dynamically loads libicui18n.so.48 specifically

strace shows the following:
open("/usr/lib/libicui18n.so.48", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

Installing aur/icu48 provides the required .so to fix this issue. It only is required when rendering a PDF with unicode character encoding in the HTML, so maybe opt-depend it? The build for that package is currently failing, but I uploaded a fixed source package for it ( http://kageurufu.net/icu48-4.8.1.1-3.src.tar.gz ) and I'm just waiting for a response from the maintainer

phillid commented on 2015-01-28 08:24

psytoolkit, could you please try installing/updating icu? It might be a dependency I missed when adding them to the list.

psytoolkit commented on 2015-01-27 19:12

When running version 0.12.2.1, it runs, but I get the message:

Unable to load library icui18n "Cannot load library icui18n: (icui18n cannot open shared object file: No such file or directory)

phillid commented on 2015-01-26 23:37

That's odd, it's working fine this way... Could you please:

* Confirm that makepkg says the source's sum is correct
* Let me know about anything special you've set in /etc/makepkg.conf that I might be overlooking.
* Confirm that running `bsdtar tf /path/to/wkhtmltox-0.12.2.1_linux-wheezy-amd64.deb | grep 'data'` outputs 'data.tar.xz'

Thanks.