Package Details: wkhtmltopdf-static 0.12.5-1

Git Clone URL: https://aur.archlinux.org/wkhtmltopdf-static.git (read-only)
Package Base: wkhtmltopdf-static
Description: Shell utility to convert HTML to PDF using Webkit and Qt (upstream static build)
Upstream URL: https://wkhtmltopdf.org/
Licenses: GPL3
Conflicts: wkhtmltopdf
Provides: wkhtmltopdf=0.12.5
Submitter: foutrelis
Maintainer: phillid
Last Packager: phillid
Votes: 51
Popularity: 0.182349
First Submitted: 2010-02-06 14:46
Last Updated: 2018-08-20 10:04

Required by (14)

Sources (2)

Latest Comments

1 2 3 4 5 Next › Last »

gkrukar commented on 2019-04-30 07:59

Without ttf-dejavu wkhtmltopdf generate broken pdf. Example: https://filebin.net/b4ulc0v0g007ulb8/Zapisy_kart_pracy__8_.pdf?t=rry48lum On my server i had to install ttf manually after installing wkhtmltopdf-static

phillid commented on 2019-04-30 07:48

@gkrukar, could you please describe the problem?

gkrukar commented on 2019-04-29 18:29

Hello I had small problem with this package it was resolved by installing ttf-dejavu. Could you add ttf font to dependencies?

phillid commented on 2018-08-20 10:06

Thanks for the heads up, dcelasun. I have switched the package to use static builds for Ubuntu Bionic Beaver.

dcelasun commented on 2018-08-14 09:57

Working PKGBUILD for 0.12.5:

# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
# Maintainer : David Phillips <dbphillipsnz gmail dot com>

pkgname=wkhtmltopdf-static
pkgver=0.12.5
pkgrel=1
pkgdesc="Shell utility to convert HTML to PDF using Webkit and Qt (upstream static build)"
arch=('i686' 'x86_64')
url="http://wkhtmltopdf.org/"
license=('GPL3')
conflicts=('wkhtmltopdf')
provides=("wkhtmltopdf=${pkgver}")
depends=('bzip2' 'expat' 'fontconfig' 'freetype2' 'gcc-libs' 'glib2' 'glibc' 'graphite' 'harfbuzz' 'libjpeg-turbo' 'libpng' 'libx11' 'libxau' 'libxcb' 'libxdmcp' 'libxext' 'libxrender' 'pcre' 'zlib' 'libpng12')
optdepends=('icu48: Rendering from HTML uses unicode character encoding')

# Debian packages are already stripped, so don't bother re-attempting
options=('!strip')
source_x86_64=("https://github.com/wkhtmltopdf/wkhtmltopdf/releases/download/${pkgver}/wkhtmltox_${pkgver}-1.xenial_amd64.deb")
source_i686=("https://github.com/wkhtmltopdf/wkhtmltopdf/releases/download/${pkgver}/wkhtmltox_${pkgver}-1.xenial_i386.deb")
md5sums_i686=('e8f5b97f0924d8d28413382306f86cc5')
md5sums_x86_64=('a5d8f1803d01f0128addf767efd77944')

package() {
    tar -xJf data.tar.xz -C "${srcdir}"
    mkdir -p "${pkgdir}/usr"
    cp "${srcdir}/usr/local/"* "${pkgdir}/usr" -r

    mkdir -p "${pkgdir}/usr/share"
    cp "${srcdir}/usr/share/"* "${pkgdir}/usr/share" -r
}

phillid commented on 2017-06-28 03:33

Thank you for the heads up, I have updated these.

ryan-au commented on 2017-06-28 02:12

The source URLs in the PKGBUILD no longer work (download.gna.org times out), and the project's download page now links to files on GitHub. Can the PKGBUILD please be updated?

phillid commented on 2017-04-29 23:13

For what it's worth, these messages can be somewhat suppressed by forcing wkhtmltopdf to use the old openssl-1.0 (now packaged in /usr/lib/openssl-1.0/ by package openssl-1.0) with LD_LIBRARY_PATH

kageurufu commented on 2017-04-28 16:03

https://github.com/wkhtmltopdf/wkhtmltopdf/issues/3001

On my usage, the QSslSocket errors are output to stderr, and I'm still able to use "wkhtmltopdf - -" with pipes for input/output (Python subprocess)

Can you provide more details?

Koterpillar commented on 2017-04-28 10:41

The QSslSocket error messages are printed to the standard output, not standard error, breaking use use of "-" for output file.