Package Details: wingpanel-indicator-ayatana-git r36.8533b03-1

Git Clone URL: https://aur.archlinux.org/wingpanel-indicator-ayatana-git.git (read-only, click to copy)
Package Base: wingpanel-indicator-ayatana-git
Description: Wingpanel Ayatana-Compatibility Indicator
Upstream URL: https://github.com/elementary/wingpanel-indicator-ayatana
Licenses: GPL3
Conflicts: wingpanel-indicator-ayatana
Provides: wingpanel-indicator-ayatana
Replaces: wingpanel-indicator-ayatana-bzr
Submitter: alucryd
Maintainer: quequotion
Last Packager: alucryd
Votes: 0
Popularity: 0.000000
First Submitted: 2017-05-28 10:23
Last Updated: 2017-05-28 10:23

Latest Comments

quequotion commented on 2020-10-07 14:52

@DAC324

This, like wingpanel-indicator-ayatna ought to depend on gtk3-ubuntu rather than gtk3, but does not for reasons of policy.

Alas, it is a moot point. It is not, nor is it ever likely to be, possible to compile this software for Archlinux. One of the dependencies, libindicator-gtk3-ubuntu is using deprecated API. As I understand it, Ubuntu has no motivation to develop their own indicator API any further, since they were forced to abandon Unity and revert to GNOME Shell as their DE.

That said, I am kind of working on it, with no success to report yet. Should I figure it out, I intend to update this package to source from a community-maintained fork of the indicator which is theoretically still in development. In addition, given hopelessness of this package ever being promoted to [community], I'll change the dependency to gtk3-ubuntu.

DAC324 commented on 2020-09-29 08:57

This package does not compile:

idomenuitemfactory.c:21:10: fatal error: gtk/ubuntu-private.h: No such file or directory
   21 | #include <gtk/ubuntu-private.h>
      |          ^~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]:  [Makefile:669: idomenuitemfactory.lo] Error 1
make[2]: Leaving directory '/home/gerd/.cache/yay/ido-ubuntu/src/src'
make[1]:  [Makefile:509: all-recursive] Error 1
make[1]: Leaving directory '/home/gerd/.cache/yay/ido-ubuntu/src'
make: *** [Makefile:415: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
error making: ido-ubuntu

alucryd commented on 2020-06-23 07:43

@quequotion: Honestly I don't care about ancient ayatana indicators, I'll disown so you can do as you deem is best.

quequotion commented on 2020-06-11 12:50

Since development of the original wingpanel-indicator-ayatana has ended, a new community-developed fork is getting updates.

How would you feel about replacing these packages with it?

I could upload an additional wingpanel-indicator-ayatana-community-git, but I'd prefer to avoid having too many packages with similar names and purposes in the AUR if at all possible.

alucryd commented on 2017-05-28 10:26

Just pushed the git version, but note that I will never include it in any repo, official or unofficial, and will never support it due to it requiring patched ubuntu crap like gtk3-ubuntu.

quequotion commented on 2017-05-25 10:55

There's a git repository available for this now:
https://github.com/elementary/wingpanel-indicator-ayatana

NoMoreBullshit commented on 2016-02-11 10:16

wingpanel-indicator-ayatana-bzr/src/wingpanel-indicator-ayatana/src/AyatanaIndicator.vala:262.63-262.74: error: Argument 2: Cannot convert from `Gdk.Pixbuf' to `string?'
button = new Wingpanel.Widgets.Button (label, image.pixbuf);
^^^^^^^^^^^^
Compilation failed: 1 error(s), 1 warning(s)
src/CMakeFiles/ayatana_compatibility.dir/build.make:92: recipe for target 'src/ayatana_compatibility_valac.stamp' failed
make[2]: *** [src/ayatana_compatibility_valac.stamp] Error 1
CMakeFiles/Makefile2:85: recipe for target 'src/CMakeFiles/ayatana_compatibility.dir/all' failed
make[1]: *** [src/CMakeFiles/ayatana_compatibility.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2